The CreateProcessWithLogonW() Function Ignores the startinfo.wShowWindow Flag (818858)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
  • Microsoft Windows Small Business Server 2003, Premium Edition
  • Microsoft Windows Small Business Server 2003, Standard Edition

SYMPTOMS

When you call the CreateProcessWithLogonW function, the startinfo.wShowWindow flag is ignored. For example, if you want to hide the program that you start, the program is visible after it starts.

CAUSE

The flag is not passed to the kernel function that actually implements the call.

RESOLUTION

Windows XP

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name      Platform
   ---------------------------------------------------------------------
   22-May-2003  17:18  5.1.2600.1224  1,586,176  Advapi32.dll   IA64
   12-May-2003  17:30  5.1.2600.1221    227,456  Ksecdd.sys     IA64
   22-May-2003  17:18  5.1.2600.1221     43,520  Seclogon.dll   IA64
   19-May-2003  17:49  5.1.2600.1224    566,784  Wadvapi32.dll  IA64
   12-May-2003  17:17  5.1.2600.1221     15,360  Wseclogon.dll  IA64
   22-May-2003  17:18  5.1.2600.1224    566,784  Advapi32.dll   x86
   12-May-2003  17:16  5.1.2600.1221     80,512  Ksecdd.sys     x86
   22-May-2003  17:18  5.1.2600.1221     15,360  Seclogon.dll   x86

Windows Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size       File name      Platform
   -------------------------------------------------------------------
   06-Jun-2003  18:12  5.2.3790.51  1,384,960  Advapi32.dll   IA64
   06-Jun-2003  18:12  5.2.3790.51     44,544  Seclogon.dll   IA64
   06-Jun-2003  18:13  5.2.3790.51    562,176  Wadvapi32.dll  IA64
   06-Jun-2003  18:13  5.2.3790.51     16,896  Wseclogon.dll  IA64
   06-Jun-2003  18:13  5.2.3790.51    562,176  Advapi32.dll   x86
   06-Jun-2003  18:13  5.2.3790.51     16,896  Seclogon.dll   x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Windows XP

This problem was first corrected in Microsoft Windows XP Service Pack 2.

Modification Type:MinorLast Reviewed:10/25/2005
Keywords:kbHotfixServer kbQFE kbQFE kbWinXPsp2fix kbWinServ2003preSP1fix kbWinXPpreSP2fix kbfix kbbug KB818858