Cannot install a mass storage device on a RIPrep image (818719)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Server
  • Microsoft Windows XP Professional

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

You may not be able to install a mass storage device on a RIPrep image. When you try to add the driver, you may receive an "Access Denied" error message.

CAUSE

This issue occurs because the registry permissions are configured incorrectly on the following registry keys when you install a RIPrep image:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DISK

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MOUNTEDDEVICES

WORKAROUND

To work around this issue, use any one of the following methods.

Before you create the RIPrep image

Before you create the RIPrep image, install the disk device that you want on the computer where you create the RIPrep image. When you install the device before you create the RIPrep image, the registry keys are configured correctly, and the device drivers are installed on computers where you install the image.

After you install the RIPrep image

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

Configure the permissions to give the administrator full access to the registry keys that are described in the "Cause" section. To do so, follow these steps:
  1. Click Start, click Run, type regedt32 in the Run box, and then click OK.
  2. Locate, and then right-click the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DISK

  3. Click Permissions, and then click Administrators under Group or user names.
  4. Under Permissions for Administrators, click to select the Allow check box next to Full Control, and then click OK.
  5. Locate, and then right-click the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MOUNTEDDEVICES

  6. Click Permissions, and then click Administrators under Group or user names.
  7. Under Permissions for Administrators, click to select the Allow check box next to Full Control, and then click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about RIPrep images, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:6/14/2004
Keywords:kbwinservsetup kbFilePrintservices kbprb KB818719