SYMPTOMS
The information store may dismount without generating an
error message or error event. When you remount the store, it dismounts again
after a short time. When you perform additional troubleshooting steps to
determine the cause of this problem, you may experience one or more of the
following behaviors:
- When you mount a blank store, it does not automatically
dismount until a
client
program logs on.
- When the
client
program connects to the blank store, you receive a message that the client
program is retrieving data from the Exchange
server, and then the information store dismounts.
CAUSE
This problem occurs if the information store tries to create
a token object for a domain distinguished name (also known as DN) where the
domain
controller (DC) portion is made up of lowercase letters
(
dc=). This problem may also occur if a user distinguished
name contains lowercase
domain
controller separators (
dc=).
The
information store
tokenm code uses a case-sensitive
STRSTR function to locate the
DC= portion of the
distinguished name. If the distinguished name uses lowercase letters similar to
the following example, the
tokenm code cannot determine the
domain controller:
cn=username,cn=users,dc=domain,dc=corp,dc=example,dc=com
RESOLUTION
Cumulative Rollup Information
To resolve this problem, obtain the September 2003 Exchange 2000 Server Post-Service Pack 3 (SP3) Rollup. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824282 September 2003 Exchange 2000 Server Post-Service Pack 3 Rollup
Hotfix Information
A supported fix
is now available from Microsoft, but it is only intended to correct the problem
that is described in this article. Apply it only to computers that are
experiencing this specific problem. This fix may receive additional testing.
Therefore, if you are not severely affected by this problem, Microsoft
recommends that you wait for the next Microsoft Exchange 2000 Server service
pack that contains this fix.
To resolve this problem immediately,
contact Microsoft Product Support Services to obtain the fix. For a complete
list of Microsoft Product Support Services phone numbers and information about
support costs, visit the following Microsoft Web site:
NOTE: In special cases, charges that are ordinarily incurred for
support calls may be canceled if a Microsoft Support Professional determines
that a specific update will resolve your problem. The typical support costs
will apply to additional support questions and issues that do not qualify for
the specific update in question.
Component: Information
store
The English version of this
fix has the file attributes (or later) that are listed in the following table.
The dates and times for these files are listed in coordinated universal time
(UTC). When you view the file information, it is converted to local time. To
find the difference between UTC and local time, use the
Time
Zone tab in the Date and Time tool in Control Panel.
Date Time Version Size File name
--------------------------------------------------
23-Apr-2003 20:16 6.0.6458.0 65,536 Tokenm.dll
Note Because of file dependencies, this update requires Microsoft
Exchange 2000 Server Service Pack 3 (SP3).
For additional information, click the
article number below to view the article in the Microsoft Knowledge Base:
301378 How to Obtain the Latest Exchange 2000 Server Service Pack