Only one dial-up connection program starts if many connection programs are installed in Windows XP (818534)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

If you install more than one remote access connection program, only one of the connection programs starts correctly. For example, if you install The Microsoft Network (MSN) software, and then you install AOL software, the AOL software may start, but the MSN software does not start.

CAUSE

This problem occurs because Microsoft Windows XP recognizes only the first .dll file that is listed in the HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Rasman\Parameters\CustomDLL subkey.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version        Size     File name            Operating system
------------------------------------------------------------------------------------------
03-Jul-2003  16:38  5.1.2600.1243  163,840  Rasmans.dll          Windows XP 32-bit edition
03-Jul-2003  16:38  5.1.2600.1243  490,496  Rasmans.dll   IA-64  Windows XP 64-bit edition
03-Jul-2003  14:50  5.1.2600.1243  163,840  Wrasmans.dll  x86    Windows XP 64-bit edition 

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

If you write a remote access custom-dial .dll file for Windows XP, you must register that file in the HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Rasman\Parameters\CustomDLL subkey. The CustomDLL subkey contains a list of custom-dial .dll files. Although more than one custom-dial .dll file may be listed in the CustomDLL subkey, Windows XP reads only the first custom-dial .dll file that is listed. If the custom-dial .dll file that you have written does not start the list, the customer dialer program does not start when you double-click the phone book entry. If the list starts with the custom-dial .dll file that you have written, the custom-dialer program starts. However, other demand dialer programs may stop working. For additional information about standard terminology used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE ATdownload kbWinXPsp2fix kbRegistry kbClient kbBroadBand kbRemoting kbfix kbBug kbQFE kbWinXPpreSP2fix KB818534 kbAudEndUser kbAudDeveloper