"Setup Cannot Copy the File <FileName>" Error Messages Occur When You Perform an In-Place Upgrade of Windows Server 2003 (818464)



The information in this article applies to:

  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Small Business Server 2003, Standard Edition
  • Microsoft Windows Small Business Server 2003, Premium Edition

,

SYMPTOMS

When you perform an in-place upgrade of Windows Server 2003, you receive the following error messages during the Graphical User Interface (GUI)-mode portion of Setup:
Setup cannot copy the file FileName
You receive this error message for each file that Setup cannot copy. The following file names may be referenced in this error message:

Cmprops.dl_
Licwmi.dl_
Mmfutil.dl_
Servereps.dl_

Additionally, when you view the Scesetup.log file in the %Windir%\Security folder on the hard disk, you may receive the following error messages:
Error 1208: An extended error has occurred.

Error opening %Windir%\Security\Database\secedit.sdb.

-and-

Error 1208: An extended error has occurred.

Errors occurred.

-and-

Error 1208: An extended error has occurred.

Error creating database.

CAUSE

This problem occurs because the security database, Secedit.sdb, is damaged. The security database may be damaged in situations where the computer is shut down incorrectly.

RESOLUTION

To resolve this problem, use the Esentutl.exe command-line utility to repair the database, and then run Windows Server 2003 Setup. To repair the database by using Esentutl.exe:
  1. Click Start, and then click Run.
  2. In the Open box, type the following line, and then press ENTER:

    esentutl /p %windir%\security\database\secedit.sdb

  3. Click Start, and then click Run.
  4. In the Open box, type the following line, and then press ENTER:

    %windir%\security

  5. Right-click the Edb.log file and the Edb0000x.log file, and then click Delete.
  6. Click OK when you are prompted to confirm the deletion.
Note When you perform this procedure, some data loss may result. For example, cached local security policy settings may be lost.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:3/1/2004
Keywords:kbprb KB818464