File operation takes 35 seconds or longer on a down-level server running an SMB service (818396)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Server SP3
  • Microsoft Windows 2000 Professional SP3

SYMPTOMS

On a Microsoft Windows 2000-based computer, when you perform a file operation to a down-level (non-Microsoft Windows NT-based) server that is running a server message block (SMB) service, for example an OS/2 Warp 4 server, the file operation may take approximately 35 seconds or longer to complete.

For example, this problem may occur when you open a file or when you modify file attributes on the down-level server.

Also, overall computer performance may decrease when your Windows 2000-based computer accesses files on the down-level server.

This problem may occur after you do one or both of the following:
  • Install Microsoft Windows 2000 Service Pack 3 (SP3).
  • Install the fix that is described in the following Microsoft Knowledge Base article:

    301952 Slow Performance When You Access Files on Servers

CAUSE

This problem occurs when a total file lock (oplock) is sent to the client that issued the request, and the client does not answer. As a result, the server waits for the oplock timeout to occur. On an OS/2 server, the minimum break oplock timeout is 35 seconds.

RESOLUTION

Part 1: Download and Install the Update

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date        Time  Version       Size    File name
   --------------------------------------------------
   04-Jun-2003 17:18 5.0.2195.6752 407,792 Mrxsmb.sys
   04-Jun-2003 17:18 5.0.2195.6752 168,496 Rdbss.sys

Part 2: Turn Off Opportunistic Locking

After you install this update on a Windows 2000-based computer, turn off opportunistic locking. To do this, follow these steps:
  1. Quit all Windows 2000 programs.
  2. Click Start, and then click Run.
  3. In the Open box, type regedit and then click OK.
  4. Locate, and then select the following key in the Windows registry:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MrXSmb\Parameters\

  5. On the Edit menu, point to New, and then click DWORD Value.
  6. Type OplocksDisabled, and then press ENTER.
  7. Right-click OplocksDisabled, and then click Modify.
  8. In the Value data box, type 1, and then click OK.
  9. On the Registry menu, click Exit.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

296264 Configuring opportunistic locking in Windows

For more information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the following article number to view the article in the Microsoft Knowledge Base:

265173 The Datacenter Program and Windows 2000 Datacenter Server product


Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbQFE kbfix kbbug KB818396