SMS: Network Monitor Pattern Match May Not Work with a Saved Display Filter (818245)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0

SYMPTOMS

If you save a display filter that contains a pattern match to a file and you then later use the display filter to filter a Systems Management Server (SMS) Network Monitor capture, the frames that match the criteria may not appear in Network Monitor. This problem occurs if the pattern includes the Unicode "00" character.

CAUSE

When Network Monitor saves the display filter, "00" is incorrectly written as "0" (a single zero) to the file.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SMS service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version    Size       File name   Platform
   --------------------------------------------------------------
   06-May-2003  21:31  5.0.943.3  1,011,712  Netmon.exe  x86
Note Because of file dependencies, the most recent hotfix or feature that contains these files may also contain additional files.

How to Install the Hotfix

Using the Hotfix Installer

Note This method is only for Intel-based computers.
  1. Create a folder in a location that is accessible to the computers that need this hotfix.
  2. Copy the Q818245.exe update file and the platform folders to the new folder. The folder structure must be such that the update file is located one folder "above" the platform folders.
  3. On each of the computers that runs SMS Network Monitor, log on to the computer by using an account with administrator credentials.
  4. Run Q818245.exe and then follow the instructions in the wizard. This fix is intended only for computers that have the SMS version of Network Monitor installed.

Using a Manual Installation

Replace the %SystemRoot%\System32\NetmonFull\Netmon.exe file with the version from the hotfix.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

WORKAROUND

When you save a Network Monitor display filter that has, for example, the following pattern

'5C 00 4F 00 75 00 74 00 70 00 75 00 74 00 5C'

the saved .df file contains:

Line3=1,97,0,1,TCP,:Data,0,1002,4,15,5c04f07507407007507405c,TCP:Data contains '5C 00 4F 00 75 00 74 00 70 00 75 00 74 00 5C'

To correct the problem, change the contents to:

Line3=1,97,0,1,TCP,:Data,0,1002,4,15,5c004f007500740070000750074005c,TCP:Data contains '5C 00 4F 00 75 00 74 00 70 00 75 00 74 00 5C'


Modification Type:MinorLast Reviewed:10/6/2005
Keywords:kbQFE kbSMS200preSP5fix kbBug kbfix KB818245