You receive the "Microsoft SQL Server login" error message when you connect to Microsoft Project Server (818047)



The information in this article applies to:

  • Microsoft Project 2002
  • Microsoft Project Server 2002
  • Microsoft Office Project Professional 2003
  • Microsoft Office Project Server 2003

SYMPTOMS

When you try to connect to either Microsoft Project Server 2002 or to Microsoft Office Project Server 2003 from Microsoft Project 2002 or from Microsoft Office Project 2003, you may receive the following error message:
Microsoft SQL Server Login
Connection failed: SQLState: '01000'
SQL Server Error: 2
[Microsoft][ODBC SQL Server Driver][Named Pipes]ConnectionOpen (CreateFile()).
Connection failed:
SQLState: '08001'
SQL Server Error: 6
[Microsoft][ODBC SQL Server Driver][Named Pipes]Specified SQL server not found.

CAUSE

This problem may occur if the SQL Server is using a protocol other than TCP/IP.

RESOLUTION

To resolve this problem, follow these steps.

Part 1: On the Computer That Contains the SQL Server

  1. Click Start, and then click Run.
  2. In the Open box, type Cliconfg.exe, and then click OK.
  3. In the SQL Server Client Network Utility dialog box, do the following on the General tab:
    1. Depending on the version of MDAC you have installed, do one of the following:
      • Click Default Network Library from the drop down list.
      • Use the Up/Down arrows to move the enabled protocols in the order you that you want. However, TCP/IP is the Default Network Library and must be moved to the top of the list.
    2. Click to clear the Force protocol encryption check box.
  4. Click OK to close the SQL Server Client Network Utility dialog box.
  5. Restart the SQL Services.

Part 2: Configure the Client Computer to Use TCP/IP

Note If the problem still occurs after you follow the steps that are listed in Part 1, run the Cliconfg utility on the client computer. To do this, follow these steps:
  1. Log on to the Microsoft Project Professional 2002 client computer or the Microsoft Office Project Professional 2003 client computer.
  2. Click Start, and then click Run.
  3. In the Open box, type Cliconfg.exe, and then click OK.
  4. On the General tab, click TCP/IP, and then click OK.

Modification Type:MinorLast Reviewed:1/7/2006
Keywords:kberrmsg kbprb KB818047