Roaming Profiles Are Not Unloaded on a Computer That Is Running Terminal Services (817171)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0, when used with:
    • the operating system: Microsoft Windows 2000
  • Microsoft Internet Explorer 6.0 SP1, when used with:
    • the operating system: Microsoft Windows 2000

For an Internet Explorer 5.5 version of this article, see 294268.

SYMPTOMS

After you install Internet Explorer version 6 or version 6 Service Pack 1 (SP1) on a Windows 2000-based computer that is running Terminal Services, if the "Important URLs & Favorites and Links" Windows 2000 Group Policy is enabled, Index.dat files may not be deleted on the server when a user logs off from a Windows 2000 Terminal Services client. This problem may occur even though the "Delete cached roaming profiles" group policy is enabled. This problem does not occur in Microsoft Internet Explorer versions 5.0 and 5.01 or if the "Important URLs & Favorites and Links" Windows 2000 Group Policy is not enabled.

CAUSE

Cached profile folders are created but not completely deleted because three Index.dat files cannot be deleted in three different subfolders. Therefore, every time a user logs on and off, new folders are created on the computer that is running Terminal Services in the user_name, user_name.000, user_name.001 format. A new folder is created for each user. These folders quickly fill the hard disk of the computer that is running Terminal Services.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Internet Explorer 6 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size       File name
   -----------------------------------------------------------
   07-Apr-2003  23:08  6.0.2800.1186   1,026,048  Browseui.dll
   07-Apr-2003  23:10  16.0.2800.1186    294,912  Iedkcs32.dll
				
Note The hotfix installer name for this issue is Q817171.EXE.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbIE600sp2fix kbIE600preSP2fix kbfix kbbug KB817171