Server may stop responding if a Winsock program is under a heavy load in Windows 2000 (816960)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

In certain situations, when a Winsock program that is running on your Microsoft Windows 2000-based server is under a heavy load, Afd.sys may consume 100 percent of the CPU. As a result, the server may stop responding (hang). You may experience these symptoms if you use a large send buffer and send a lot of data over a socket in a short period of time.

CAUSE

This problem occurs if a value that tracks the amount of memory that is cached is not decremented correctly, and as a result, Afd.sys enters a state where it consumes 100 percent of CPU usage.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version         Size    File name
--------------------------------------------------------
18-Mar-2003  02:12  5.0.2195.6602  108,816  Msafd.dll        
18-Mar-2003  02:12  5.0.2195.6601   17,680  Wshtcpip.dll     
18-Mar-2003  02:11  5.0.2195.6687  119,024  Afd.sys
11-Mar-2003  20:19  5.0.2195.6682  314,672  Tcpip.sys
15-Jan-2003  19:56  5.0.2195.6655   16,240  Tdi.sys

Note This update requires Microsoft Windows 2000 Service Pack 3.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the following article number to view the article in the Microsoft Knowledge Base:

265173 The Datacenter program and Windows 2000 Data Server product

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbQFE kbWin2000preSP4Fix kbfix kbbug KB816960 kbAudITPRO