"Device Not Ready" Error Message When You Try to Shut Down a Windows XP Workstation Remotely (816938)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional SP1

SYMPTOMS

When you try to shut down a Windows XP-based workstation remotely, you may receive the following error message:
Device Not Ready
This error message may occur if you connect to the remote computer by using the Remote Desktop Connection software, you log off the remote computer, and you later try to use a Remote Procedure Call (RPC) transport utility such as Shutdown.exe to shut down the remote computer. When this problem occurs, you receive the error message and the remote computer does not shut down.

CAUSE

This problem is caused by an incorrect state in the logon software (Winlogon.exe) on the computer that you are trying to shut down. The problem may occur if you connect to the remote computer by using the Remote Desktop Connection software and you log off the remote computer.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   --------------------------------------------------------
   21-Mar-2003  12:45  5.1.2600.1189  517,632  Winlogon.exe

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows XP Service Pack 2.

Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbQFE kbWinXPpreSP2fix kbfix kbbug KB816938