You receive an "Access denied" or a "Sharing violation" error message when you try to delete files on the network by using Windows Explorer in Windows XP SP1 (816474)



The information in this article applies to:

  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP 64-Bit Edition Version 2002 SP1

SYMPTOMS

After you install Service Pack 1 (SP1) on your Microsoft Windows XP-based computer, you may receive one of the following error messages when you try to delete files that you have selected over the network in Windows Explorer:
Access denied
Sharing violation

CAUSE

This problem occurs because the Microsoft Windows Shell reads the metadata of the file over the network every time that you select the file for deletion.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows XP
   Date         Time   Version         Size       File name
   -----------------------------------------------------
   07-Mar-2003  10:51  6.0.2800.1182   8,240,128  Shell32.dll
Windows XP, 64-Bit Edition
   Date         Time   Version        Size        File name    Platform
   --------------------------------------------------------------------
   07-Mar-2003  10:51  6.0.2800.1182  14,367,232  Shell32.dll  IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

For additional information about deleting files over the network in Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:

811492 It may take 35 seconds to delete files over the network


Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbQFE kbfix kbBug kbprb KB816474 kbAudITPRO