FrontPage Publishing on Application Center through ISA Is Not Successful (815931)



The information in this article applies to:

  • Microsoft Application Center 2000 SP1



Important This article contains information about editing the metabase. Before you edit the metabase, verify that you have a backup copy that you can restore if a problem occurs. For information about how to do this, see the "Configuration Backup/Restore" Help topic in Microsoft Management Console (MMC).

SYMPTOMS

When you use ISA Server in front of an Application Center cluster, the FrontPage client cannot connect to the cluster if the request is forwarded to the cluster controller through the Application Center request forwarder. Connecting directly to the Application Center controller works without error.

CAUSE

A FrontPage request through ISA Server to an Application Center cluster is processed as an HTTP 1.0 request. If a cluster member receives the FrontPage request, the Application Center request forwarder must forward the request to the cluster controller. Because of a problem in the way the Application Center request forwarder handles the HTTP 1.0 request, the FrontPage request times out.

RESOLUTION

Warning If you edit the metabase incorrectly, you can cause serious problems that may require you to reinstall any product that uses the metabase. Microsoft cannot guarantee that problems that result if you incorrectly edit the metabase can be solved. Edit the metabase at your own risk.

Note Always back up the metabase before you edit it.

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Service Pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name   
   -----------------------------------------------------
   25-Mar-2003  12:55  1.0.441.20  181,456  Rffilext.dll                                             
For this scenario to work, the following requirements must be met:
  • The FrontPage Web site must NOT be configured to use Integrated security. You can only use FrontPage through ISA Server to author FrontPage Web sites on an Application Center cluster if the Web site is not using Integrated security.
  • Application Center request forwarding for FrontPage requests must be enabled.
  • The hotfix must be installed and the metabase property that is described in the "Important Installation Note" section must be set on the cluster controller.
Important Installation Note

After you install the hotfix on all cluster nodes, you will still experience the problem. To enable the request forwarder to handle HTTP 1.0 requests correctly, you must add a metabase property on the cluster controller. The metabase property will be automatically replicated to all cluster members. To create the property, use the Mdutil.exe command line tool:
"mdutil.exe set AppCenter/Cluster -prop 57624 -dtype DWORD -utype 200 -value 0"
Mdutil.exe is available on the Application Center product CD in the Support folder.

Important Removal Note

If the hotfix does not install correctly and you do a rollback, or if you remove the hotfix, you must correct the permissions on the \Program Files\Microsoft Application Center\RFFiltExt.dll file. Specifically, Everyone must be added with Read and Execute permissions.

WORKAROUND

To work around the problem, you can directly connect with FrontPage to the Application Center cluster controller through the dedicated IP address.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/6/2005
Keywords:kbQFE KB815931 kbAudDeveloper