Third-Party Print Management Program Does Not Work as Expected After You Upgrade to Windows Server 2003 or Windows XP (815913)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows Small Business Server 2003, Premium Edition
  • Microsoft Windows Small Business Server 2003, Standard Edition


IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you upgrade your computer from Microsoft Windows NT 4.0 or Microsoft Windows 2000, third-party print management programs or printing system extension programs, such as print quota or print logging programs may stop responding or may be unstable.

CAUSE

This issue may occur if the third-party print server program relies on the file name of the spool file for job identification. The new Spool File Pooling feature in the Windows Server 2003 and the Windows XP operating system interrupts this functionality.

RESOLUTION

To resolve this issue, turn off spool file pooling by editing the Windows registry.

Note Because spool file pooling increases printing performance, do not turn it off unless your third-party printing program requires it for correct operation.

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To Turn Off Spool File Pooling on a Per Printer Queue-Basis

  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate the following registry subkey, where <printername> is the name of your printer:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Printers\<printername>

  3. In the right pane, right-click SpoolDirectory, and then click Modify.
  4. In the Value data box, type the location where you want the spool files to be stored.

    For example, type c:\windows\system32\spool\printers as the default location.
  5. Quit Registry Editor.

To Turn Off Spool File Pooling for All Printers

Note This method only works on Windows 2003 servers. This method does not work for Windows XP.
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate the following registry subkey:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print

  3. On the Edit menu, point to New, and then click DWORD Value.
  4. In the New Value #1 box, type DisableServerFilePooling, and then press ENTER.
  5. Right-click DisableServerFilePooling, and then click Modify.
  6. In the Value data box, type 1 to turn off spool file pooling, and then click OK.
  7. Quit Registry Editor.

MORE INFORMATION

Certain third-party print spool programs use the spool files for job information. When spool file pooling is turned on in Windows, these programs may not work as expected because the spool files are reused. You can use the DisableServerFilePooling registry value to turn off spool file pooling on the server, overriding individual printer settings that may be configured.

Modification Type:MajorLast Reviewed:4/5/2004
Keywords:kbBug kbprb KB815913