XCON: Message Header Information Is Inserted in Plain Text Message Body (815622)



The information in this article applies to:

  • Microsoft Exchange Server 5.5

IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you use Microsoft Outlook Express to view a plain text e-mail message, the message header information is inserted in the message body.

CAUSE

This behavior may occur when the following conditions are true:
  • A plain text e-mail message is sent from an IMAP4 (Internet Message Access Protocol, Version 4rev1) program to a Microsoft Exchange 2000 Server computer.
  • The message is then routed to a Microsoft Exchange Server 5.5 computer.
  • The message is opened in Outlook Express or another MAPI (Messaging Application Programming Interface) program that is running on a Microsoft Windows 2000-based computer.

MORE INFORMATION

A supported feature that modifies the product's default behavior is now available from Microsoft, but it is only intended to modify the behavior that this article describes. Apply it only to systems that specifically require it. This feature may receive additional testing. Therefore, if the system is not severely affected by the lack of this feature, we recommend that you wait for the next Microsoft Exchange Server version 5.5 service pack that contains this feature.

To obtain this feature immediately, contact Microsoft Product Support Services. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site: Component: MTA

The global version of this feature has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size    File name
   --------------------------------------------------
05-Mar-2003  20:20     5.5.2657.29    491,280   Mdbmsg.dll
05-Mar-2003  20:23     5.5.2657.29  2,629,392   Store.exe

				

MORE INFORMATION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To apply this hot fix, you must first edit the registry to add a new registry value. To add the new registry value:
  1. Click Start, click Run, type REGEDIT, and then click OK.
  2. Expand HKEY_LOCAL_MACHINE, expand System, expand Current ControlSet, expand Services, expand msexchangeis, and then expand ParametersSystem.

    Note To expand a registry key, click the plus sign next to the registry key folder.
  3. Click InternetContent, click Edit, point to New, and then click DWORD Value.
  4. Type PreserveFidelityPopImap, and then press ENTER to name the new value.
  5. Double-click PreserveFidelityPopImap.
  6. In the Value Data box, type 1, and then click OK.
  7. Close Registry Editor.


Note Because of file dependencies, this feature requires Microsoft Exchange Server 5.5 Service Pack 4 (SP4).

Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbfix kbExchange550preSP5fix kbbug KB815622 kbAudITPRO