WD2002: Custom Toolbar in Template Causes Word to Error When Exiting (815621)



The information in this article applies to:

  • Microsoft Word 2002

SYMPTOMS

After you create a new document based on a template that contains a custom docked toolbar, and then exit Word, you may receive the following error message:
Microsoft Word has encountered a problem and needs to close. We are sorry for the inconvenience. To see what data this error report contains, click here.
When you click the "click here" link, you receive an error signature similar to the following:
   AppName       AppVer        ModName       ModVer        Offset
   ----------------------------------------------------------------
   Winword.exe   10.0.2627.0   Winword.exe   10.0.2627.0   00028980

CAUSE

This problem may occur if you quit Word and both the following conditions are true:
  • A docked custom toolbar was added to a new toolbar line in the template.

    -and-
  • The Styles and Formatting task pane is open.

RESOLUTION

Service Pack Information

This problem is corrected in Office XP Service Pack 3.To resolve this problem, obtain the latest service pack for Microsoft Office XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

307841 How to obtain the latest Office XP Service Pack

Hotfix Information

A supported fix is now available from Microsoft, but it is only intended to correct the problem described in this article. Only apply it to systems that are experiencing this specific problem. This fix may receive additional testing to further ensure product quality. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Microsoft Office XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this fix should have the following file attributes or later:
   Date         Time   Size       File name
   --------------------------------------------------------------
   24-Mar-2003  09:20  8,294,604  Winwordff.msp  (full file)
   24-Mar-2003  07:54  3,002,028  Winwordop.msp  (client)
After the hotfix is installed, the English version of this fix will have the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   21-Mar-2003  19:06  10.0.5119.0    10,603,080  Winword.exe   				
This fix is a post-Office XP Service Pack 2 (SP-2) fix. To install the fix, you must have Office XP SP-2 installed. For additional information about Office XP SP-2, click the following article number to see the article in the Microsoft Knowledge Base:

325671 OFFXP: Overview of the Office XP Service Pack 2

Additionally, you may have to install Windows Installer 2.0 to install this fix. For additional information about the Windows Installer requirement for post-Office XP SP-2 fixes, click the following article number to see the article in the Microsoft Knowledge Base:

330537 OFFXP: Office XP Updates and Patches Released After September 2002 May Require Windows Installer 2.0

Note The Full-File version of this patch will install on Office XP Service Pack 1 (SP1). However it has not been tested to the same extent on that version as it has on the latest service pack, and some unanticipated file conflicts are possible. This configuration is supported, but not recommended.


WORKAROUND

To work around this problem, use one of the following methods.

Method 1: Close the Task Pane

To close the task pane, click Task Pane on the View menu.

Method 2: Create an AutoClose Macro

Microsoft provides programming examples for illustration only, without warranty either expressed or implied, including, but not limited to, the implied warranties of merchantability and/or fitness for a particular purpose. This article assumes that you are familiar with the programming language being demonstrated and the tools used to create and debug procedures. Microsoft support professionals can help explain the functionality of a particular procedure, but they will not modify these examples to provide added functionality or construct procedures to meet your specific needs. If you have limited programming experience, you may want to contact a Microsoft Certified Partner or the Microsoft fee-based consulting line at (800) 936-5200. For more information about Microsoft Certified Partners, see the following Microsoft Web site: For additional information about the support options available from Microsoft, visit the following Microsoft Web site: To create an AutoClose macro that automatically closes the task pane when you quit Word, follow these steps:
  1. Close all open documents.
  2. On the File menu, click Open, and then open the template that contains the custom toolbar.
  3. On the Tools menu, point to Macro, and then click Visual Basic Editor.
  4. On the Insert menu, click Module.
  5. On the module code sheet, type the following macro example:
    Sub AutoClose()
    
       ' Close the task pane if open
       CommandBars("Task Pane").Visible = False
    
    End Sub
    
  6. On the File menu, click Close and Return to Microsoft Word.
  7. To save your changes to the template, on the File menu, click Save.
  8. To close the template, on the File menu, click Close.

Method 3: Undock the Custom Toolbar

Change the custom toolbar to a floating custom toolbar. To do this, follow these steps:
  1. Close all open documents.
  2. On the File menu, click Open, and then open the template that contains the custom toolbar.
  3. On the Tools menu, click Customize.
  4. Drag the docked custom toolbar away from the toolbar area and put it anywhere in the document area.
  5. In the Customize dialog box, click Close.
  6. To save your changes to the template, on the File menu, click Save.
  7. To close the template, on the File menu, click Close.

Method 4: Move to a Default Toolbar Line

Move the custom toolbar to a default toolbar line. To do this, follow these steps:
  1. Close all open documents.
  2. On the File menu, click Open, and then open the template that contains the custom toolbar.
  3. On the Tools menu, click Customize.
  4. Drag the docked custom toolbar and put it on an existing standard toolbar line.

    For example, move the custom toolbar to the end of the Formatting toolbar.
  5. In the Customize dialog box, click Close.
  6. To save your changes to the template, on the File menu, click Save.
  7. To close the template, on the File menu, click Close.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Office XP Service Pack 3.

MORE INFORMATION

For more information about custom toolbars, click Microsoft Word Help on the Help menu, type custom toolbar in the Office Assistant or the Answer Wizard, and then click Search to view the topics returned.

Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kberrmsg kbbug kbfix kbofficexppresp3fix KB815621