FIX: Password Synchronization Leaves Defunct Processes on UNIX Server (815479)



The information in this article applies to:

  • Microsoft Windows Services for UNIX 3.0

SYMPTOMS

The UNIX client stops responding or system performance deteriorates.

CAUSE

The following processes eventually use up most system resources and cause the symptoms listed earlier:
  • Each time a password is synchronized from Windows to Solaris or to HP/UX, an orphaned (or defunct) process may be left running on the UNIX client.
  • Each time a synchronization does not succeed, it results in four orphaned processes on the UNIX system.
After a while, if these processes are not cleaned up, they use up most system resources and cause the UNIX client to crash, or system performance deteriorates.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next version that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time    Size    File name
   --------------------------------------
   21-Apr-2003  21:00  213,949  Ssod.h10
   21-Apr-2003  21:00  226,480  Ssod.h11
   21-Apr-2003  21:00  781,548  Ssod.so7

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

The files included in this fix are installed on the UNIX operating system. To install the hotfix, follow these steps:
  1. Start a command prompt in the directory that you downloaded the hotfix to.
  2. Run the following command: SFU3-815479-X86.exe /x
  3. Type in a temporary directory. It can be the one that contains the hotfix file. The files will be extracted to the \Bins folder.
  4. Follow the instructions in "Help for Services for UNIX", and use the appropriate file from this folder, instead of from the installation CD.

Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbQFE KB815479