"Software Restriction Policy Does Not Allow You to Start This Program" Error Message Even Though the Program Is Defined As "Allowed" (815471)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition


SYMPTOMS

After you define a software restriction policy that defaults to "Disallowed," and you then define paths to specific locations for "Allowed" programs, you may receive the following error message when you try to run the allowed program:
Software restriction policy does not allow you to start this program.

CAUSE

This issue may occur if the software restriction policy does not handle the Novell Netware network provider correctly. In this scenario, the Netware share is interpreted as a local device instead of as a remote device. Therefore, the software restriction policy is not effective on the Microsoft Windows XP client.

Note This issue does not occur when the program is run from a Windows server share that has the same software restriction policy.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date          Time   Version         Size     File name
   ----------------------------------------------------------
   04-Jun-2003   11:26  5.1.2600.1230   566.272  Advapi32.dll  
   12-May-2003   10:16  5.1.2600.1221    80.512  Ksecdd.sys 
   04-Jun-2003   11:16  5.1.2600.1230   156.800  Nwrdr.sys  	

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

For additional information about software restriction policies in Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:

310791 Description of the Software Restriction Policies in Windows XP

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kberrmsg kbQFE kbWinXPpreSP2fix kbfix kbbug KB815471