FIX: MSIB/MCMS Channel Structure Is Hard-Coded (815459)



The information in this article applies to:

  • Microsoft Solution Offering - Microsoft Solution for Internet Business

SYMPTOMS

When you use the Microsoft Solution for Internet Business 2.0 Content Connector, you receive the following error message if the site's channel hierarchy is in a non-default location:
Message can only be called for channel urls that begin with '/Channels/Cultures/' "Could not retrieve default simple product posting path from Commerce Server resources"

CAUSE

The site's channel hierarchy is hard-coded to '/Channels/Cultures/' in the solution.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next release that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version    Size    File name
   -------------------------------------------------------------------------------
   10-Mar-2003  23:23  2.0.350.0  90,112  Microsoft.solutions.contentconnector.dll  
   10-Mar-2003  23:23  2.0.350.0  90,112  Microsoft.solutions.shared.dll  
To use this hotfix:
  1. Install the fix that is described in this article.
  2. Modify your existing site's Web.config file as follows:
    1. In the <sectionGroup name="SiteSettings"> section or node, add the following line:
      <section name="MlsChannelContext" type="Microsoft.Solutions.Framework.SiteConfigurationHandler, Microsoft.Solutions.Shared, Version=2.0.345.0, Culture=neutral,
      PublicKeyToken=31bf3856ad364e35"/>
    2. In the <SiteSettings> section or node, add the following lines:
      <!-- BEGIN: MlsChannelContext Configuration -->
      		<MlsChannelContext>
      			<!-- DefaultRootPath: Default Root channel path for use by GetPath methods that do not take an overriding rootPath parameter -->
      			<Param name="DefaultRootPath" value="/Channels/Cultures/" type="System.String"/>
      		</MlsChannelContext>
      <!-- END: MlsChannelContext Configuration -->
      	
      Note You can modify this section to reflect the location where the channel hierarchy resides.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE KB815459 kbAudDeveloper