Reached the Maximum Number of Connections Too Soon for a Shared Folder (815432)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

CPR - WinXP - Hotfix in SP2

SYMPTOMS

When you try to connect to a shared folder, you may receive the following error message:
No more connections can be made to this remote computer at this time because there are already as many connections as the computer can accept

CAUSE

This behavior occurs because one or more programs connect to and disconnect from the shared folder on a short cycle, especially when the disconnect and reconnection time to the shared folder is less than one second. In these circumstances, the disconnected session does not have sufficient time to expire before the new connection is made. As a result, there may be several disconnected sessions that are waiting to expire. These sessions count toward the maximum number of connections for the shared folder until they expire.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP

   Date         Time   Version        Size     File name
   ------------------------------------------------------
   25-Feb-2003  15:29  5.1.2600.1174  400,896  Mrxsmb.sys
   25-Feb-2003  15:29  5.1.2600.1174  154,880  Rdbss.sys

Windows XP, 64-Bit Edition

   Date         Time   Version        Size       File name
   --------------------------------------------------------
   25-Feb-2003  15:29  5.1.2600.1174  1,259,392  Mrxsmb.sys
   25-Feb-2003  15:29  5.1.2600.1174    489,216  Rdbss.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbQFE kbWinXPsp2fix kbWinXPpreSP2fix kbbug kbfix KB815432