SMS: Clients Do Not Check for New Programs at the Correct Interval (815373)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0
  • Microsoft Systems Management Server 2.0 SP1
  • Microsoft Systems Management Server 2.0 SP2
  • Microsoft Systems Management Server 2.0 SP3
  • Microsoft Systems Management Server 2.0 SP4
  • Microsoft Systems Management Server 2.0 SP5

SYMPTOMS

If you configure a Systems Management Server (SMS) client to check for new programs at a particular interval that is different from the site-wide setting, the client performs the check every 60 minutes regardless of the client and site-wide intervals settings.

Note To set the client-specific interval, open the Advertised Programs Monitor tool in Control Panel, click System, click Options, and then specify the interval in the Check for new programs every box.

CAUSE

This problem occurs only if you have permitted clients to configure their own Advertised Programs Monitor settings. The Advertised Programs Monitor does not correctly use the client-specific polling interval.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Systems Management Server service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name         Platform
   -------------------------------------------------------------------------
   01-May-2002  19:55  2.0.92.9          391,923  Apasetup.exe         X86
   01-May-2002  17:55  2.0.1493.4163     182,096  Ccim32.dll           X86
   01-May-2002  19:55  2.0.92.9        1,324,791  Ccmcore.exe          X86
   01-May-2002  19:55  2.0.1493.4187   1,238,432  Clibase.dll          X86
   01-May-2002  19:55  2.0.1493.4187   3,409,631  Clicore.exe          X86
   01-May-2002  12:05  2.0.1493.4105      88,432  Clisvcl.exe          X86
   01-May-2002  19:55  2.0.1493.4187       8,512  Cliver.exe           X86
   01-May-2002  19:55                         67  Compverbase.ini      
   01-May-2002  19:55                         67  Compversmsapm32.ini  
   01-May-2002  19:55                         67  Compverswdist.ini    
   01-May-2002  15:45  2.0.1493.4149      34,656  Cqmgr32.dll          X86
   01-May-2002  16:30  2.0.1493.4146      54,128  Odpsys32.exe         X86
   01-May-2002  16:30  2.0.1493.4146      60,784  Odpusr32.exe         X86
   01-May-2002  19:55  2.0.1493.4187     253,808  Smsapm32.exe         X86
   01-May-2002  19:55  2.0.1493.4187     118,208  Smsmon32.exe         X86
   01-May-2002  19:55  2.0.1493.4187     109,504  Smswiz32.exe         X86
   01-May-2002  19:55  2.0.92.9          640,740  Swdist32.exe         X86
  
   01-May-2002  19:55  2.0.92.9          638,993  Apasetup.exe         Alpha
   01-May-2002  17:55  2.0.1493.4163     295,184  Ccim32.dll           Alpha
   01-May-2002  19:55  2.0.92.9        1,926,769  Ccmcore.exe          Alpha
   01-May-2002  19:55  2.0.1493.4187   1,960,720  Clibase.dll          Alpha
   01-May-2002  19:55  2.0.1493.4187   4,453,326  Clicore.exe          Alpha
   01-May-2002  12:05  2.0.1493.4105     125,712  Clisvcl.exe          Alpha
   01-May-2002  19:55  2.0.1493.4187      13,584  Cliver.exe           Alpha
   01-May-2002  19:55                         67  Compverbase.ini      
   01-May-2002  19:55                         67  Compversmsapm32.ini  
   01-May-2002  19:55                         67  Compverswdist.ini    
   01-May-2002  15:45  2.0.1493.4149      55,056  Cqmgr32.dll          Alpha
   01-May-2002  16:30  2.0.1493.4146      75,536  Odpsys32.exe         Alpha
   01-May-2002  16:30  2.0.1493.4146      83,216  Odpusr32.exe         Alpha
   01-May-2002  19:55  2.0.1493.4187     333,072  Smsapm32.exe         Alpha
   01-May-2002  19:55  2.0.1493.4187     175,888  Smsmon32.exe         Alpha
   01-May-2002  19:55  2.0.1493.4187     168,208  Smswiz32.exe         Alpha
   01-May-2002  19:55  2.0.92.9          694,789  Swdist32.exe         Alpha

	
Note Because of file dependencies, the most recent hotfix or feature that contains these files may also contain additional files.

How to Install the Hotfix

Using the Hotfix Installer

Note This method is only for Intel-based computers.

  1. Create a folder in a location that is accessible to your SMS site servers.
  2. Copy the Sms2.0-kb815373-spx-x86-enu.exe update file (where x is the service pack version) and platform folders to the new folder. In the folder structure, the update file must be located one folder-level above the platform folders.
  3. From each of the primary and secondary SMS site servers in your environment, log on to your site server by using an account with administrative credentials.
  4. Quit the SMS Administrator console if it is running.
  5. Run Sms2.0-kb815373-spx-x86-enu.exe, and then follow the instructions in the wizard.

Manual Installation

  1. Create a folder in a location that is accessible to your SMS site servers.
  2. Copy the platform folders that contain the hotfix files to the folder you just created.
  3. From each of the primary and secondary SMS site servers in your environment, log on to your site server by using an account with administrative credentials.
  4. Quit the SMS Administrator console if it is running.
  5. Stop all SMS services.
  6. Replace the following files in the SmsRootFolder\Bin\Platform folder with the versions from the hotfix:
    • Ccim32.dll
    • Clisvcl.exe
    • Cqmgr32.dll
    • Odpsys32.exe
    • Odpusr32.exe
    • Smsapm32.exe
  7. Replace the Swdist32.exe file in the SmsRootFolder\Inboxes\Clicomp.src\SWDist\Platform folder with the version from the hotfix.
  8. Replace the Apasetup.exe file in the SmsRootFolder\Inboxes\Clicomp.src\Smsapm32\Platform folder with the version from the hotfix.
  9. Replace the files Ccmcore.exe and Clicore.exe in the SmsRootFolder\Inboxes\Clicomp.src\Base\Platformfolder with the versions from the hotfix.
  10. Replace the Compver.ini file in the SmsRootFolder\Inboxes\Clicomp.src\SWDist folder with the Compverswdist.ini file from the hotfix. Note that you must rename the Compverswdist.ini file as Compver.ini.
  11. Replace the Compver.ini file in the SmsRootFolder\Inboxes\Clicomp.src\Smsapm32 folder with the Compversmsapm32.ini file from the hotfix. Note that you must rename the Compversmsapm32.ini file as Compver.ini.
  12. Replace the Compver.ini file in the SmsRootFolder\Inboxes\Clicomp.src\Base folder with the Compverbase.ini file from the hotfix. Note that you must rename the Compverbase.ini file as Compver.ini.
  13. Restart SMS Services.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

WORKAROUND

Do not permit clients to configure their own Advertised Programs Monitor polling interval. To prevent clients from configuring this setting in the SMS Administrator Console, follow these steps:
  1. Navigate to the following folder:

    Site Database\Site Hierarchy\SiteCode\Site Settings\Client Agents

  2. Double-click Advertised Programs Client Agent, and then on the General tab, click to select the Client cannot change agent settings check box.
Advertised Programs Monitor now uses the site-wide polling interval.

MORE INFORMATION

If you permit clients to configure their own Advertised Programs Monitor polling interval, this hotfix will update the SMS client so that it correctly saves and uses each user's interval if set by the user. The setting is sent to Available Programs Manager (APM) at user logon. When a user logs on who has a longer interval than the site-wide setting, the setting will be sent to APM but not applied until the next Offer Data Provider (ODP) cycle. If a user has a shorter interval than the site-wide setting, this will trigger an immediate ODP cycle and the setting will be applied directly after the ODP cycle.

At user logoff, APM will revert to the site-wide polling interval. That interval can be configured through the Check for new programs every setting on the General tab. To locate this tab, see step 2 in the "Workaround" section of this article.

Note that when you install this fix, the load on Client Access Points (CAPs) may increase because the clients now start honoring their client-side polling intervals.

In Microsoft Windows 95, Microsoft Windows 98, and Microsoft Windows Millennium Edition (Me), the client-side polling interval setting is shared among all users unless Windows has been set up to use per-user profiles. To configure profiles in Windows 95, Windows 98, and Windows Me, click the User Profiles tab in the Passwords tool in Control Panel.

Although this article discusses the polling interval, it also makes sure that the other client settings available in the Advertised Programs Monitor Control Panel tool are correctly applied to each user.

Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbSMS200preSP6fix kbfix kbBug KB815373