The computer does not resume from hibernation or does not Wake-on-LAN from standby (815304)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

When your Microsoft Windows XP-based computer resumes from hibernation (S4), or attempts to Wake-on-LAN from standby (S3) you may experience one or more of the following symptoms:
  • The screen is not displayed correctly, and garbled characters may appear.
  • The screen appears blank.
  • The computer stops responding.
The symptoms may vary, depending on what video adaptor is installed in your computer.

CAUSE

This problem may occur in one of the following scenarios:
  • You have Windows XP Service Pack 1 (SP1) installed.
  • You have the hotfix that is described in the following Microsoft Knowledge Base article installed:

    306676 The computer cannot enter standby or hibernate if a Direct3D-based screen saver is running

  • Your computer that is running Windows XP Service Pack 2 (SP2) has Wake-on-LAN enabled, and the computer resumes from S3 (standby) power state because of a network ping request, such as the request generated by a Remote Desktop (RDP) connection.

RESOLUTION

Hotfix information

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows XP 64-bit versions
   Date         Time   Version         Size       File name      Platform
   ----------------------------------------------------------------------
   14-Jan-2005  16:44  5.1.2600.1619   1,485,312  User32.dll     IA-64
   14-Jan-2005  05:01  5.1.2600.1619   5,630,080  Win32k.sys
   14-Jan-2005  16:47  5.1.2600.1619     557,056  Wuser32.dll    x86
Windows XP 32-bit versions
   Date          Time   Version         Size       File name   Platform
   --------------------------------------------------------------------
   114-Jan-2005  16:47  5.1.2600.1619   574,464    User32.dll  x86 
   14-Jan-2005   05:28  5.1.2600.1619   1,845,888  Win32k.sys  x86 
   14-Jan-2005   05:50  5.1.2600.2597   1,836,032  Win32k.sys  x86 

WORKAROUND

To work around the hibernation (S4) problem, temporarily turn off the Hibernation feature. To do this, follow these steps:
  1. Click Start, and then click Control Panel.
  2. Double-click Power Options.
  3. Click the Hibernation tab.
  4. Click to clear the Enable Hibernation check box, and then click OK.

    Note There is no workaround for the Wake on LAN issue from S3 except for the fix described in this article.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbQFE kbWinXPsp2fix kbWinXPpreSP2fix kbfix kbbug KB815304 kbAudEndUser kbAudITPRO