Only two clients can create a TCP connection after you install SQL Server 2000 SP2 or SP3 (815295)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

After you install Microsoft SQL Server 2000 Service Pack 2 (SP2) or SQL Server 2000 Service Pack 3 (SP3) on a Microsoft Windows 2000 Server-based computer that has the Routing and Remote Access service installed and running as a network address translation (NAT) server, only two internal clients can create a TCP connection through the NAT server to an outside server.

CAUSE

This problem occurs when you install either SQL Server 2000 SP2 or SQL Server 2000 SP3. During the installation of either service pack, the installer sets the following registry key to the value 1433-1434:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\ReservedPorts

The Windows 2000 NAT driver then reads this key and limits the outgoing NAT TCP/UDP source port mappings to this range. Because the default setting for this registry key is for two ports, only two internal clients can create a TCP connection through the NAT server to an outside server.

After you apply the hotfix that is described in the "Resolution" section, the NAT driver uses the following registry key range value to limit outgoing NAT TCP/UDP source port mappings:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\IPNAT\parameters\ReservedPorts

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart Requirement

You must restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size    File name
   ----------------------------------------------------
   03-Jul-2003  20:26  5.0.2195.6768  67,120  Ipnat.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about how to use the ReservedPorts registry key, click the following article number to view the article in the Microsoft Knowledge Base:

812873 How to reserve a range of ephemeral ports on a computer that is running Windows Server 2003 or Windows 2000 Server

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/13/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWin2000preSP5fix KB815295 kbAudITPRO