"Your Interactive Logon Privilege Has Been Disabled" Error When You Try to Log on to a Terminal Server (815266)



The information in this article applies to:

  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition



IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you try to log on to a Microsoft Windows 2003-based terminal server, you may receive the following error message:
Your interactive logon privilege has been disabled. Please contact your system administrator.

CAUSE

This issue may occur if you try to use the Guest user account to log on after you add the account to the built-in Remote Desktop Users security group. You may also receive this error if you try to log on by using any user account that is denied Read permissions to Active Directory directory service.

This behavior occurs because the domain Guest user account is denied Read permissions to their user account information in Active Directory. When an account is denied the Read permission to their Active Directory or local account information in the Windows Security Account Manager (SAM) database, the logon request is unsuccessful because the operating system cannot determine if the user has permission to log on to Windows.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

For 32-bit systems

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   21-Jul-2004  23:38  5.2.3790.193      540,672  Winlogon.exe     
   19-Jul-2004  06:32                        271  Branches.inf
   22-Jul-2004  05:12                      9,766  Kb815266.cat
   20-Jul-2004  03:21                        354  Updatebr.inf
   22-Jul-2004  03:31                      5,657  Update_rtmqfe.inf

For 64-bit systems

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   19-Jul-2004  09:30  5.2.3790.193      638,464  Winlogon.exe     IA64
   18-Jul-2004  21:22                        271  Branches.inf
   22-Jul-2004  05:12                      9,766  Kb815266.cat
   22-Jul-2004  03:45                        354  Updatebr.inf
   22-Jul-2004  03:45                      5,677  Update_rtmqfe.inf

WORKAROUND

To work around this issue, edit the Windows registry on the terminal server so that it causes the Winlogon process to ignore errors reading the Terminal Services Configuration data, and so that it reads the DefaultUserConfig data instead. To do so, follow these steps.

Warning: After you follow these steps, a user account whose Read permissions to the local SAM database or to Active Directory, you have intentionally removed to prevent their logon to the terminal server, will be able to log on to the terminal server.
  1. Click Start, click Run, type regedit in the Open box, and then click OK.

    WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  2. Locate the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server

  3. On the Edit menu, point to New, and then click DWORD Value.
  4. In the New Value #1 box, type IgnoreRegUserConfigErrors, and then press ENTER.
  5. Right-click IgnoreRegUserConfigErrors, and then click Modify.
  6. In the Value data box, type 1 (one), click Decimal, and then click OK.
  7. Quit Registry Editor.

Modification Type:MinorLast Reviewed:9/30/2005
Keywords:kbHotfixServer kbQFE KB815266