Feature Pack: Patch Installation Does Not Start at the Correct Time If Universal Coordinated Time (UTC) Is Specified (815007)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0

SYMPTOMS

The Patch Installation Agent (PatchInstall.exe) that is included with the Systems Management Server (SMS) Software Update Services Feature Pack may not start the installation of a required patch at the expected time if you specify both a grace period and Universal Coordinated Time (UTC). Instead of running at the specified interval after the authorized time in UTC, the patch may run at the specified interval in the client's local time.

CAUSE

This problem specifically affects regions that do not use daylight saving time -- for example Japan and the (GMT +9:00) Osaka, Sapporo, Tokyo time zone. In these time zones, a grace period is enforced relative to the local system time instead of relative to UTC. SMS clients in time zones that do not have the option to select or clear the Automatically adjust clock for daylight saving changes check box (in Control Panel) may experience this issue.

Note To determine a client's time zone, open Control Panel, double-click Date and Time, and then click the Time Zone tab.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
	Date         Time   Version         Size       File name         Platform
	-------------------------------------------------------------------------
	15-Jan-2003  00:01  1.0.200.102       245,850  Patchinstall.exe  x86
	15-Jan-2003  00:09  1.0.200.102     1,462,272  Patchwiz_enu.exe  x86


Note Because of file dependencies, the most recent hotfix or feature that contains these files may also contain additional files.

How to Install the Hotfix

To install the hotfix, run Setup for the appropriate PatchWizard: PatchWiz_XXX.exe (where XXX represents the 3-digit language code). To upgrade to this version, you must remove the existing installation. Setup detects and prompts for the removal of previous installations of the Patch Wizard. Note that when you remove the previous installation, this does not delete any existing packages.

To modify and refresh existing Packages and Updates with the updated Patchinstall.exe file, follow these steps:
  1. In the SMS Administrator Console, click the Site Database node.
  2. On the Action menu, click All Tasks, and then click Distribute Software Updates.
  3. In the Distribute Software Updates Wizard, click Next until you reach the Create an SMS Package, or modify Packages and Updates page.
  4. Select the existing package that you want to refresh, and then continue through the wizard. Modifications are not required to refresh the package and Distribution Points with the updated version of PatchInstall.exe.
  5. Repeat these steps for each package that you want to refresh.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/18/2005
Keywords:kbHotfixServer kbQFE kbprb KB815007