Windows Stops Responding with "Stop Error 0x7F" Error Message (814789)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Server SP3
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Professional SP3
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

SYMPTOMS

Your Windows 2000-based computer or Windows XP-based computer that is running Terminal Services may stop responding, and then you receive the following error message on a blue screen:
0x0000007f (0x00000008) error STOP 0x7f
The Win32k.sys file is listed as the source of the Stop error.

When you shut down and restart your computer, the computer starts normally. However, the Stop error recurs regularly.

CAUSE

Currently Windows 2000 permits a program to create up to 100 nested windows. During cleanup, there may not be sufficient stack space for the current thread to handle all the functions needed to clean up all the window objects.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows 2000 and Windows XP service packs that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows 2000

  Date         Time     Version          Size     File name
  ---------------------------------------------------------------
  04-Mar-2003  19:26   5.0.2195.6678     42,768   Basesrv.dll
  14-Feb-2003  18:49   5.0.2195.6660    222,992   Gdi32.dll
  14-Feb-2003  18:49   5.0.2195.6656    710,928   Kernel32.dll
  04-Mar-2003  19:26   5.0.2195.6669    333,072   Msgina.dll
  31-Jan-2003  18:51   5.0.2195.6661     90,232   Rdpwd.sys
  04-Mar-2003  19:26   5.0.2195.6666    379,664   User32.dll
  04-Mar-2003  19:26   5.0.2195.6671    385,296   Userenv.dll
  04-Mar-2003  19:24   5.0.2195.6679  1,620,176   Win32k.sys
  03-Mar-2003  15:14   5.0.2195.6675    181,008   Winlogon.exe
  14-Feb-2003  18:49   5.0.2195.6655    243,472   Winsrv.dll
  04-Mar-2003  19:33   5.0.2195.6661     90,200   56bit\Rdpwd.sys
  04-Mar-2003  19:26   5.0.2195.6656    710,928   uniproc\Kernel32.dll
  04-Mar-2003  19:26   5.0.2195.6679  1,620,176   uniproc\Win32k.sys
  14-Feb-2003  18:49   5.0.2195.6655    243,472   uniproc\Winsrv.dll
				

Windows XP

   Date         Time   Version        Size       File name   Platform
   ------------------------------------------------------------------
   15-Jan-2004  01:49  5.1.2600.1332  1,678,208  Win32k.sys  i386
   15-Jan-2004  01:50  5.1.2600.1332  5,623,808  Win32k.sys  IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:

265173 The Datacenter Program and Windows 2000 Datacenter Server Product


Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbshell kbWin2kSP4fix kberrmsg kbWin2000preSP4Fix kbfix kbbug KB814789