IISSync.exe Stops Responding on a Windows 2000 Cluster Node Where Exchange 2000 Server is Installed (814754)



The information in this article applies to:

  • Microsoft Exchange 2000 Enterprise Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server

SYMPTOMS

When you run the IISSync.exe command-line utility on a Microsoft Windows 2000-based computer that is running the Cluster service to synchronize a clustered Web site or FTP site, the IISSync.exe program may stop responding (hang).

Additionally, all Microsoft Exchange 2000 Server-related resources that depend on Microsoft Internet Information Services (IIS), such as the IMAP4, POP3, and SMTP resources, enter a failed state. They failover to the other cluster node but do not come online.

CAUSE

This issue may occur if you run the IISsync.exe utility on a cluster server where Exchange 2000 Server is installed. This issue may also occur if a "deadlock" occurs when the COMREPL program that is called by IISSync.exe tries to reinstall the "Workflow Event Sink" COM+ Application that is installed by Exchange 2000 Server.

WORKAROUND

To work around this issue, follow these steps:
  1. Shut down the Workflow Event Sink on both the source and destination servers that you tried to synchronize by using the IISSync.exe program. To do so, follow these steps:
    1. Click Start, point to Programs, point to Administrative Tools, and then click Component Services.
    2. Expand Component Services, expand Computers, expand My Computer, and then expand COM+ Applications.
    3. Right-click Workflow Event Sink, and then click Shut down.
  2. On both the source and destination computers, note the following role memberships for the Workflow Event Sink:

    Can Register Workflow
    Privileged Workflow Authors

  3. On both the source and destination computers, remove the Workflow Event Sink from the COM catalog. To do so, follow these steps:
    1. Click Start, click Run, type cmd in the Open box, and then click OK.
    2. Change the directory to the following folder location:

      Program Files\Exchsrvr\Bin

    3. Type regsvr32 /u cdowfevt.dll, and then press ENTER.
    4. When you receive the following message: DllUnregisterServer in cdowfevt.dll succeeded, click OK.
  4. Run the IISSync.exe utility to replicate changes from the clustered IIS server to the other server.
  5. On both the source and destination computers, reinstall the Workflow Event Sink into the COM catalog. To do so, follow these steps:
    1. Click Start, click Run, type cmd in the Open box, and then click OK.
    2. Change the directory to the following folder location:

      Program Files\Exchsrvr\Bin

    3. Type regsvr32 cdowfevt.dll, and then press ENTER.
    4. When you receive the following message: DllUnregisterServer in cdowfevt.dll succeeded, click OK.
  6. On both the source and destination servers, restore the role memberships for the Workflow Event Sink that you noted in step 2, by adding each user to the appropriate role.
  7. Run the workflow setup (Wfsetup.vbs) program that is included with the Microsoft Exchange Software Development Kit (SDK).

    To obtain the Microsoft Exchange SDK Development Tools, visit the following Microsoft Web site:Note By default, when you install the Exchange SDK Development Tools, the Wfsetup.vbs file is stored in the following location:

    C:\Program Files\Exchange SDK\Tools\WorkflowSetup

  8. When you receive the message that states that workflow setup is complete, click OK.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Windows 2000 Server.

MORE INFORMATION

The last phase of the COMREPL process re-installs the COM+ Applications, and stops responding when it prompts the Workflow Event Sink COM dynamic link Library (DLL) to register. DllRegisterServer in Cdowfevt.dll calls the InstallWorkflow function. This function first checks if the workflow application is already registered with COM+ by enumerating the COM+ catalog. However, because the COM+ catalog is designed to lock all processes out during this procedure, a deadlock occurs where the InstallWorkflow function cannot install the Workflow Event Sink, and the COMREPL process waits for the Workflow Event Sink to be reinstalled before returning to IISSync.exe.

Modification Type:MinorLast Reviewed:4/30/2003
Keywords:kbnofix kbBug kbprb KB814754