Visual Studio .NET Analyzer tool may not work correctly after you repair it (814719)



The information in this article applies to:

  • Microsoft Visual Studio .NET (2003), Professional Edition
  • Microsoft Visual Studio .NET (2003), Enterprise Architect Edition
  • Microsoft Visual Studio .NET (2003), Enterprise Developer Edition
  • Microsoft Visual Studio .NET (2003), Academic Edition
  • Microsoft Visual Studio .NET (2002), Professional Edition
  • Microsoft Visual Studio .NET (2002), Enterprise Architect Edition
  • Microsoft Visual Studio .NET (2002), Enterprise Developer Edition
  • Microsoft Visual Studio .NET (2002), Academic Edition

SYMPTOMS

If you remove Microsoft Visual Studio .NET 2002 on a computer that has Microsoft Visual Studio .NET 2003 already installed, the Visual Studio Analyzer tool may not work correctly. After you run the Registeranalyzerv7.bat file to repair the tool, Visual Studio Analyzer still may not work correctly.

CAUSE

This problem occurs because some files that the Visual Studio .NET 2003 version of Visual Studio Analyzer uses become corrupted when you remove Visual Studio .NET 2002.

WORKAROUND

To work around this problem, you must manually register the default ProfDefV7.dll file. To do this, follow these steps:
  1. Click Start, and then click Run.
  2. In the Run dialog box, type the following command in the Open text box

    Regsvr32 "Root\Program Files\Microsoft Visual Studio .NET 2003\Common7\Tools\Analyzer\Bridges\WMI\ProfDefV7.dll"

    where Root is the root folder where Visual Studio .NET 2003 is installed.
  3. Click OK to register the DLL.

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Steps to reproduce the behavior

  1. On a test computer, install Visual Studio .NET 2002.
  2. Install Visual Studio .NET 2003.
  3. Remove Visual Studio .NET 2002.
  4. Run the Registeranalyzerv7.bat file. This file is located in the C:\Program Files\Microsoft Visual Studio .NET 2003\Common7\Tools\Analyzer folder.
  5. Verify that an entry for ProfDefV7.dll does not appear in the registry.
Note When you run the Registeranalyzerv7.bat file to repair Visual Studio Analyzer, ProfDefV7.dll is not registered automatically.

REFERENCES

For more information, visit the following Microsoft Developer Network (MSDN) Web site:

Modification Type:MinorLast Reviewed:3/6/2006
Keywords:kbvs2005swept kbvs2005doesnotapply kbvs2002sp1sweep kbpending kbVSVisAnalyzer kbDLL kbbug KB814719 kbAudDeveloper