OL2002: Outlook AppointmentItem Form That Uses Item.Recipients.ResolveAll Causes Outlook to Stop Responding (814692)



The information in this article applies to:

  • Microsoft Outlook 2002
  • Microsoft Outlook 2000

SYMPTOMS

Outlook may stop responding, or you may receive the following error message:
Microsoft Outlook has encountered a problem and needs to close. We are sorry for the inconvenience.
This issue may occur when the following conditions are true:
  • You use the ResolveAll method in a PropertyChange event in a custom Appointment form.
  • When you use the form, you add a recipient to the Scheduling tab of the form.

CAUSE

Microsoft Outlook does not handle this scenario correctly.

WORKAROUND

Microsoft provides programming examples for illustration only, without warranty either expressed or implied, including, but not limited to, the implied warranties of merchantability and/or fitness for a particular purpose. This article assumes that you are familiar with the programming language being demonstrated and the tools used to create and debug procedures. Microsoft support professionals can help explain the functionality of a particular procedure, but they will not modify these examples to provide added functionality or construct procedures to meet your specific needs. If you have limited programming experience, you may want to contact a Microsoft Certified Partner or the Microsoft fee-based consulting line at (800) 936-5200. For more information about Microsoft Certified Partners, see the following Microsoft Web site: For additional information about the support options available from Microsoft, visit the following Microsoft Web site:

To work around this problem, resolve recipients individually in the PropertyChange event. The following Microsoft Visual Basic Scripting Edition(VBScript) code illustrates how you can do this in a custom Appointment form:
Sub Item_PropertyChange(ByVal Name)

   For Each objRecip In Item.Recipients
      objRecip.Resolve
   Next

End Sub

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:6/11/2003
Keywords:kberrmsg kbprb KB814692