Reinstall of the Stand-Alone Database Version of Visual SourceSafe Removes Required Files and Folders (814679)



The information in this article applies to:

  • Microsoft Visual SourceSafe 6.0c
  • Microsoft Visual SourceSafe for Windows 6.0

SYMPTOMS

If you reinstall the stand-alone database version of Microsoft Visual SourceSafe, and then you try to start Visual SourceSafe, authentication does not succeed and you receive the following error message:
File "SourceSafeDatabasepath\srcsafe.ini" not found.
Note This behavior does not occur when you install Visual SourceSafe as a shared database server.

CAUSE

This problem occurs because some files that Visual SourceSafe requires are removed from the Database folder during the reinstall process.

RESOLUTION

To resolve this problem, restore the following files and folders to the Visual SourceSafe Database folder from a backup copy:
  • Srcsafe.ini
  • Data\Aaaaaaaa.cnt
  • Win32\Ddconv.exe
  • Win32\Ddupd.exe
  • Users
  • Data\LoggedIn
  • Temp
  • Template
Note If no backup copy is available, reinstall Visual SourceSafe as a shared database server.

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

Steps to Reproduce the Behavior

  1. Install Microsoft Visual SourceSafe 6.0.
  2. In Visual SourceSafe Setup, select the STAND-ALONE option for Database Version.
  3. In Control Panel, double-click Add or Remove Programs.
  4. Click Microsoft Visual SourceSafe 6.0, and then click Change/Remove.
  5. In the Visual SourceSafe Setup dialog box, click Reinstall.
  6. Start Visual SourceSafe 6.0.
  7. In the SourceSafe Login dialog box, type your information in the User Name text box and in the Password text box, and then click OK.

REFERENCES

For more information, visit the following Microsoft Developer Network (MSDN) Web site:

Modification Type:MinorLast Reviewed:2/20/2004
Keywords:kberrmsg kbpending kbDatabase kbSrcControl kbsetup kbbug KB814679 kbAudDeveloper