Group Policy Processing Stops After You Apply a WMI Filter to a GPO (814613)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
  • Microsoft Windows Small Business Server 2003, Standard Edition
  • Microsoft Windows Small Business Server 2003, Premium Edition

SYMPTOMS

When you apply a Windows Management Instrumentation (WMI) filter to a Group Policy object (GPO), you may experience one or both of the following symptoms:
  • That GPO may not be processed.
  • All Group Policy processing may stop.

CAUSE

This issue may occur if WMI encounters an error during Group Policy processing and stops responding.

MORE INFORMATION

When you apply a WMI filter to filter the scope of a GPO, WMI errors that are encountered during Group Policy processing are handled in the following ways:
  • When the WMI service is off:
    If the WMI service is not running, only that GPO to which you have applied the WMI filter is not processed. All other Group Policy processing continues.
  • When the WMI service is on and a known error occurs:
    If a known error is encountered, only that GPO to which you have applied the WMI filter is not processed. All other Group Policy processing continues.

    Note A known error in this case is an error for which the Group Policy feature has the error code, and for which it monitors.
  • When the WMI service is on and an unknown error occurs:
    If an error occurs for which the Group Policy feature does not have an error code and for which it does not monitor, all Group Policy processing stops (fails).

Modification Type:MajorLast Reviewed:3/1/2004
Keywords:kbprb KB814613