Registry Repair and Recovery May Inadvertently Delete a Subset of Keys (814545)



The information in this article applies to:

  • Microsoft Windows XP Home Edition SP1
  • Microsoft Windows XP Home Edition SP1a
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Professional SP1a

SYMPTOMS

After Windows starts, the registry may be missing a subset of keys under a subkey such as HKLM\Software\Classes or HKLM\Software\Classes\CLSID. Because many of these keys are required for Windows to work correctly, Explorer.exe may not start after you log on, Windows Management Instrumentation (WMI) may not work correctly, or a program may not work. If you view the registry closely (by comparing the registry with that from a working computer, or through troubleshooting), you may find many missing keys.

CAUSE

The registry resiliency code in Windows XP Service Pack 1 (SP1) removes corrupted registry keys when Windows starts, but may inadvertently delete a subset of keys.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name
   ----------------------------------------------------------
   18-Feb-2003  14:01  5.1.2600.1170  1,892,352  Ntkrnlmp.exe
   18-Feb-2003  14:02  5.1.2600.1170  1,948,288  Ntkrnlpa.exe
   18-Feb-2003  14:02  5.1.2600.1170  1,921,024  Ntkrpamp.exe
   18-Feb-2003  14:01  5.1.2600.1170  1,924,480  Ntoskrnl.exe

To prevent this problem from occurring, install the hotfix that is described in this article. If the problem has already occurred, restore the missing registry keys from a backup.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

For additional information about the registry resiliency feature, click the following article number to view the article in the Microsoft Knowledge Base:

318159 Damaged Registry Repair and Recovery in Windows XP


Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbQFE kbWinXPpreSP2fix kbfix kbbug KB814545