CPI-C Application May Stop Responding After a Network Outage (814477)



The information in this article applies to:

  • Microsoft Host Integration Server 2000
  • Microsoft Host Integration Server 2000 SP1

SYMPTOMS

A non-blocking Common Programming Interface for Communications (CPI-C) application may stop responding after a network error occurs.

In one reported instance of the problem, an CMALLC (Allocate) did not complete when it was issued after a TCP/IP socket error was returned for a previous CPI-C conversation request.

Note: This also applies to Advanced Program-to-Program Communications (APPC) applications that cancel an outstanding ALLOCATE() verb.

CAUSE

The APPC Library (Wappc32.dll) does not correctly clean up all the APPC session resources when you cancel a conversation.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Host Integration Server 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. For more information about a fix for the problem described here, click the following article number to view the article in the Microsoft Knowledge Base:

328289 APPC Session May Use Wrong Remote LU If Cancellation of Conversation Occurs


STATUS

Microsoft has confirmed that this is a problem in Microsoft Host Integration Server 2000 and Host Integration Server 2000 SP1.

MORE INFORMATION

The following scenario describes the problem:
  • A network outage occurs between Host Integration Server 2000 client (where CPI-C application is running) and the Host Integration Server 2000 (through which the LU 6.2 session to the IBM mainframe is defined).
  • A CPI-C application issues CMINIT (Initialize_Conversation) to initiate a new conversation.
  • The CPI-C application issues a CMALLC.
  • The CMALLC results in an APPC ALLOCATE being issued by the underlying APPC DLL (Wappc32.dll).
  • The CPI-C application cancels the conversation with a CMCANC (Cancel_Conversation).
  • A network error is returned to the Host Integration Server 2000 client by the TCP/IP protocol stack because the network outage occurred earlier.
  • The CPI-C application issues a CMINIT (Initialize_Conversation) to initiate a another conversation.
  • The CPI-C application issues a CMALLC.

    The CPI-C application stops responding at this point because the CPI-C DLL (wcpic32.dll) cannot call the APPC DLL to allow the APPC ALLOCATE to be issued. Control is not returned to the CPI-C DLL. As a result, the application does not respond.

Modification Type:MinorLast Reviewed:5/25/2006
Keywords:kbfix kbbug KB814477