You Cannot Use the Same WinPE Image for Both Uniprocessor and Multiprocessor-Based Computers (814199)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows XP Professional

SYMPTOMS

You may not be able to use a single WinPE image to deploy the Windows Preinstallation Environment (WinPE) to uniprocessor and multiprocessor-based computers from a Remote Installation Services (RIS) server. You may have to create separate WinPE images.

CAUSE

This problem occurs because WinPE cannot detect the multiprocessor platform. As a result, you cannot use the same WinPE image for both uniprocessor and multiprocessor-based computers. You must use separate images.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003

Date         Time   Version      Size     File name 
------------------------------------------------------
04-Aug-2003  18:02               338,032  Layout.inf 
01-Aug-2003  18:58               278,176  Setupldr.bin 
01-Aug-2003  18:59  5.2.3790.74  258,560  Setupldr.exe

Windows XP

Date         Time   Version        Size     File name 
-------------------------------------------------------- 
04-Aug-2003  22:02  2,352                   Extra.inf 
06-Aug-2003  18:06  245,920                 Setupldr.bin 
06-Aug-2003  18:06  5.1.2600.1255  226,304  Setupldr.exe 
04-Aug-2003  20:37  328,496                 Layout.inf 
04-Aug-2003  20:34  347,154                 Layout.inf 

MORE INFORMATION

To install this hotfix when the path of your WinPE image on the RIS server is \\RISServer1\Reminst\Setup\English\Images\WinPEx86Boot\I386, follow these steps:
  1. Extract the hotfix to a temporary location, and then copy the Extra.inf file to the I386 folder.
  2. Copy the KB814199.CAT file to the I386 folder.
  3. Copy the Setupldr.bin file to the I386 folder.
  4. Copy the IP\Layout.inf file to the I386\inf folder.
  5. Copy the Setupldr.exe file to the I386\templates folder, and then rename it ntldr. Back up the existing Ntldr file.
  6. Copy the I386\ntoskrnl.exe file to the I386\system32 folder.
  7. Copy the I386\ntkrnlmp.exe file to the I386\system32 folder.
  8. At a command prompt, type the following commands, and then press ENTER:

    Net stop binlsvc

    Net start binlsvc

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbQFE kbWinXPsp2fix kbWinXPpreSP2fix kbfix kbbug KB814199 kbAudITPRO