"Internet Explorer Cannot Download" Error Message When You Use an HTTPS URL to Open an Office Document or PDF File (812935)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0 SP1

SYMPTOMS

When you try to open a Microsoft Office document or a PDF file by typing an HTTPS Uniform Resource Locator (URL) for the document on the Address bar in Internet Explorer 6 Service Pack 1 (SP1), the document may not open, and you may receive the following error message:
Internet Explorer cannot download document.pdf from server

CAUSE

This issue may occur if any one or more of the following conditions are true:
  • The Do not save encrypted pages to disk check box is selected in Internet Explorer 6.0 SP1.
  • The server sends the "Cache-Control: No Store" header.
  • The server sends the "Cache-Control: No Cache" header.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Internet Explorer 6 service pack that contains this fix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

   Date         Time   Version            Size    File name
   ----------------------------------------------------------
   11-Mar-2003  08:42  6.0.2800.1174     585,728  Wininet.dll      
				

WORKAROUND

To work around this problem, make sure that Do Not Save Encrypted Files check box is not checked and that the server does not send the "Cache-Control: No Store" or the "Cache-Control: No Cache" header.

You may also be able to work around this problem by using an HREF to load the document.

Note This method does not work if the server uses the "Cache-Control: No Cache" header.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kberrmsg kbQFE kbfix kbInetDev kbBrowse kbhtml kbhttp kbIE600preSP2fix KB812935 kbAudDeveloper kbAudITPRO