XADM: Duplicate Messages Are Not Detected When You Use the PR_MESSAGE_SUBMISSION_ID Property to Identify Messages (812862)



The information in this article applies to:

  • Microsoft Exchange Server 5.5

SYMPTOMS

When you use the PR_MESSAGE_SUBMISSION_ID MAPI property to uniquely identify messages in your organization, duplicate messages are not detected. The PR_MESSAGE_SUBMISSION_ID attribute is changed between different copies of a duplicate message.

CAUSE

This behavior may occur if message journaling is configured in your organization. It occurs because the PR_MESSAGE_SUBMISSION_ID property is linked to the transport of the message and not to the content of the message.

When messages are forwarded from a recipient's mailbox server to a journal recipient that archives the messages, a new submission identifier (ID) is assigned to the message. Duplicate messages may be stored in the archive if one of the following conditions is true:
  • Multiple mailbox servers forward a copy of the same message to an archive on another server.

    -or-
  • Your organization has multiple journal servers.
Each message is assigned a different submission ID for the PR_MESSAGE_SUBMISSION_ID property.

WORKAROUND

To work around this behavior, do not use the PR_MESSAGE_SUBMISSION_ID property to identify duplicate messages. Instead, use the PR_SEARCH_KEY property. PR_SEARCH_KEY is a globally unique property. It is linked to the message content instead of to the transport envelope of each message.

MORE INFORMATION

For additional information about the PR_SEARCH_KEY property, visit the following Microsoft Web site: For additional information about how to configure message journaling, click the following article number to view the article in the Microsoft Knowledge Base:

262122 XIMS: Internet Mail Service Extension Message Journaling

For additional information about message properties, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:5/30/2003
Keywords:kbnofix kbprb kbBug KB812862