XCON: Clients Cannot Connect to Public Folders After You Change Routing Group Membership (812842)



The information in this article applies to:

  • Microsoft Exchange 2000 Enterprise Server
  • Microsoft Exchange 2000 Server

SYMPTOMS

When your MAPI client tries to connect to a public folder, you may receive the following error message:
Unable to display this folder.

CAUSE

This problem may occur if the following conditions exist:
  • The public folder request requires a referral to another public folder server to complete the request.
  • The members of the Exchange 2000 Server routing groups have been changed.
This problem occurs because the changes that are made to the routing group membership are not used until you restart the Information Store service. The Information Store computes the public folder referral information based on the routing group membership at the time that the Information Store service was started.

WORKAROUND

To work around this problem, simultaneously restart the Information Store service throughout the organization. The routing group information is then updated.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about related topics, click the following article numbers to view the articles in the Microsoft Knowledge Base:

273479 XADM: Understanding Public Folder Replication and Referrals

238614 XCON: How to Set Up Regtrace for Exchange 2000

After you have consolidated your routing groups by moving the members into another routing group and deleting the unnecessary ones, many of your clients may not be able to perform public folder referrals. If the Public Folder content is not on the local server in the routing group, the client also cannot connect to the public folder. The client receives the following error message:
Unable to display this folder.
This occurs although you are sure that public folder referral is permitted over all routing group connectors.

When you run a trace-enabled Emsmdb32.dll file, you may notice that the clients do not ever obtain a list of the servers in the organization that currently have a copy of the requested public folder from the Exchange Information Store. An entry that is similar to the following is not present in the trace, indicating that the client does not receive a response from the Information Store that lists the servers in the organization that contain a copy of the requested public folder:
12608: TIME 17:28:08 LOGONOBJ::SortServers() - Total: Owners = 2, In this Site = 2, Good = 2, Bad = 0

Modification Type:MinorLast Reviewed:6/13/2003
Keywords:kbpending kbBug kbprb KB812842