Windows NT 4.0 May Detect a Corrupted Registry and Stop Responding or Run chkdsk During Startup (812780)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 SP6a
  • Microsoft Windows NT Server 4.0 SP6
  • Microsoft Windows NT Server 4.0 SP5
  • Microsoft Windows NT Server 4.0 SP4

IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you start your Windows NT 4.0-based computer, one of the following problems may occur:
  • Windows will not start because of a corrupted Windows registry.
  • Windows may stop responding ("hang") during the start-up process.
  • Windows may automatically run the chkdsk command before starting the computer.

CAUSE

This problem may occur when your hard disk is an integrated device electronics (IDE)/ATAPI drive and the write cache of the drive was not cleared when you shut down computer. The specifications for this kind of drive do not define a cache control command. Windows NT 4.0 uses the check power mode command to clear the write cache of IDE/ATAPI hard disk drives during the shut-down process.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

153296 Write Cache on IDE/ATAPI Disks Is Not Flushed on Shut Down

This process works well for most IDE/ATAPI hard disk drives. However, some drive manufacturers (for example, Maxtor) do not support the use of the check power mode command to clear the write cache. As a result, you may experience any of the problems that are listed in the "Symptoms" section of this article.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk. A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time  Size    File name  Platform
   ----------------------------------------------
   20-Mar-2003  13:37 28,816  Atapi.sys  x86
Note Because of file dependencies, this hotfix requires Microsoft Windows NT 4.0 Service Pack 6a.


Note After you apply this hotfix, you must add the UseATAFlushCommand value to the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\atapi\Parameters

Value name: UseATAFlushCommand
Value type: DWORD
Value: 00000001

STATUS

Microsoft has confirmed that this is a problem in Windows NT 4.0.

Modification Type:MinorLast Reviewed:9/27/2005
Keywords:kbHotfixServer kbQFE kbQFE kbfix kbbug KB812780