Error Message: Another Copy Of This Application is Already Running (812488)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows 98 Second Edition

SYMPTOMS

When you try to upgrade your computer from Microsoft Windows 98 to Microsoft Windows XP, you may receive an error message similar to the following:
Another copy of this application is already running.

CAUSE

This behavior may occur if one or more of the following conditions are true:
  • A previous installation process was terminated incorrectly.
  • There are two installation processes running at the same time.
  • The Wininit.ini file on the hard disk is corrupted.

RESOLUTION

To resolve this behavior, rename each copy of Wininit.ini, and then start the Windows XP installation process. To do this, follow these steps:

Step 1: Rename Wininit.ini Files

  1. Click Start, point to Find, and then click Files or Folders.
  2. In the Named box, type wininit.ini, and then click Find Now.
  3. Right-click wininit.ini, and then click Rename.
  4. Type wininit.old, and then press ENTER.
  5. Repeat steps 3 and 4 to rename each Wininit.ini file that you find.

Step 2: Start the Windows XP Installation

  1. Press SHIFT, and then insert your Windows XP CD-ROM.
  2. Start Windows Explorer.
  3. Right-click the CD-ROM or DVD-ROM drive that contains the Windows XP CD-ROM, and then click Explore.
  4. In the left pane, click I386.
  5. In the right pane, double-click Winnt32.exe.
  6. Follow the on-screen instructions to complete the Windows XP setup and installation.

MORE INFORMATION

The Wininit.ini file contains destination paths and file names for the .dll files that are renamed and copied during a program installation or update. This method is used because some files cannot be copied if the file already exists in memory. Wininit.exe processes the Wininit.ini file when you restart the computer. If the Wininit.ini file contains incorrect information, or the renamed files have been deleted or moved, problems may occur during the restart or installation.

Modification Type:MinorLast Reviewed:4/29/2003
Keywords:kberrmsg kbprb KB812488