You Cannot Start the Component Services Snap-in and Event IDs 59 and 36 Are Logged (812485)



The information in this article applies to:

  • Microsoft Internet Information Services 5.0

SYMPTOMS

You may experience the following issues on a Microsoft Windows 2000-based computer that is running Internet Information Services (IIS) 5.0:
  • You cannot start the Component Services snap-in.

    -and-
  • Users cannot connect to Active Server Pages (ASP) pages that are located on the Web server.

    -and-
  • Events similar to the following are logged to the System Event Log:Event Type: Error
    Event Source: W3SVC
    Event Category: None
    Event ID: 59
    Description:
    The COM Application '{3D14228D-FBE1-11d0-995D-00C04FD919C1}' at '/LM/W3SVC/8/Root' failed to activate out of process. For additional information specific to this message please visit the Microsoft Online Support site located at: http://search.support.microsoft.com/search/?adv=1. Event Type: Warning
    Event Source: W3SVC
    Event Category: None
    Event ID: 36
    Description:
    The server failed to load application '/LM/W3SVC/8/Root'. The error was 'c000003b'. For additional information specific to this message please visit the Microsoft Online Support site located at: http://search.support.microsoft.com/search/?adv=1.

CAUSE

This issue may occur if Component Services is not installed correctly.

RESOLUTION

To troubleshoot and resolve this issue:

Method 1: Restart IIS

To restart Internet Information Services 5.0:
  1. Click Start, point to Programs, point to Administrative Tools, and then click Internet Services Manager.
  2. In the console tree, right-click *ServerName, where *ServerName is the name of the server, and then click Restart IIS.
  3. In the What do you want IIS to do? box, click Restart Internet Services on ServerName, and then click OK.
If restarting IIS does not resolve the issue, follow the steps in Method 2 to reinstall Component Services.

Method 2: Reinstall Component Services

To reinstall Component Services:
  1. Delete the %SystemRoot%\System32\~clbcatq.dll file (if it is present on your hard disk). To do so:
    1. Start Windows Explorer, and then locate the %SystemRoot%\System32 folder.
    2. Locate and right-click the ~clbcatq.dll file, and then click Delete.
    3. Click Yes when you are prompted to confirm the deletion.
    4. Quit Windows Explorer.
  2. Reinstall Component Services. To do so:
    1. Click Start, point to Settings, and then click Control Panel.
    2. Double-click Add/Remove Programs.
    3. Click Add/Remove Windows Components. The Windows Components Wizard starts.
    4. Click Next, and then click Finish.
    5. Click Close.
  3. Open the Component Services snap-in to verify that Component Services is installed correctly.

    Note After Component Services is installed successfully, make sure that the identity setting of IIS Out-of-Process Pooled Applications in Component Services is IWAM_ComputerName. To do so:
    1. Open the Component Service snap-in.
    2. Expand Component Services, expand Computers, expand My Computer, click COM+ Applications, right-click IIS Out-Of-Process Pooled Applications, and then click Properties.
    3. Click the Identity tab.
    4. In the Account box, click This user, and then verify that IWAM_ComputerName is displayed in the User box. If it is not displayed, click Browse, click IWAM_ComputerName in the Select User or Group dialog box that appears, and then click OK.

MORE INFORMATION

Windows 2000 Setup creates a file named ~clbcatq.dll in the %SystemRoot%\System32 folder. Windows 2000 uses ~clbcatq.dll to determine whether or not to permit access to the COM+ catalog. If the ~clbcatq.dll file is present after Setup is complete, Component Services is not installed correctly. Therefore, you cannot use the Component Services snap-in to administer the COM+ catalog, and ASP pages and Internet Server Application Programming Interface (ISAPI) .dll files do not run correctly.

If Component Services is installed correctly, the ~clbcatq.dll is deleted from the hard disk after Setup is complete. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

246499 PRB: COM+ Setup Problems While Upgrading to Windows 2000


Modification Type:MajorLast Reviewed:7/17/2006
Keywords:kbprb KB812485