Logon Is Slow After You Install SMS Client Service (812346)



The information in this article applies to:

  • Microsoft Windows 2000 Professional

IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When client computers try to log on to your Windows 2000 domain, there is a delay after the user enters his or her credentials, before logon is complete. The delay may last several minutes.

CAUSE

This issue may occur if you have installed Microsoft Systems Management Server (SMS) Client Service or Client Services for Netware, or both, on the client computer. The issue occurs because SMS Client Service has a service dependency on Remote Procedure Call (RPC) and on Client Services for Netware.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk. To resolve the issue, modify the registry settings for the SMS client service dependency. To do this, follow these steps:
  1. On the client computer, click Start, click Run, type regedit, and then click OK.
  2. Locate and double-click the following registry key: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Clisvc
  3. Remove RPCSS from the Value data box (so that it reads NWCWorkstation).
  4. Click OK, and then close Registry Editor.

Modification Type:MajorLast Reviewed:10/1/2003
Keywords:KB812346