XADM: Inetinfo Process Consumes a High Amount of Memory When You Start the SMTP Service on a Cluster Server (812275)



The information in this article applies to:

  • Microsoft Exchange 2000 Enterprise Server

SYMPTOMS

When you start the Simple Mail Transfer Protocol (SMTP) service on an Exchange 2000 Server cluster server, you may experience the following symptoms:
  • The Inetinfo.exe process is immediately allocated a lot of memory. In some cases, up to 1 gigabyte (GB).
  • The Inetinfo.exe process continues to consume additional memory that causes the following cluster resources to fail their "isalive" check:
    • The Exchange Routing service.
    • The SMTP service
    • The Post Office Protocol version 3 (POP3) service.
    • The Internet Message Access Protocol (IMAP) service.
    • The Hypertext Transfer Protocol (HTTP) service.
  • The Cluster Manager tries to restart the failed resources, and because it is unsuccessful, issues a cluster failover.

CAUSE

This issue may occur if the TempTable folders in the System mailbox contain damaged mail items.

WORKAROUND

To work around this problem, log on to the System mailbox, and then remove the contents of the TempTable folders:
  1. Log on to Windows by using an account that has domain administrator credentials.
  2. Grant the Administrator account the Send As and Receive As permissions on each of the mailbox stores:
    1. Start Exchange System Manager, and then locate the server that contains the mailbox store that you want to edit.
    2. Under the server object, expand the storage group object, and then click Properties. For example, expand First Storage Group), expand Mailbox Store (Servername), right-click Mailbox Store (Servername), and then click Properties.
    3. Click the Security tab, click the Administrator account, and then click the following check boxes in the Allow column of the Permissions list:

      Receive As
      Send As

    4. Click Apply, and then click OK.
  3. At a command prompt, type set _cluster_network_name_=clustername, and then press ENTER, where clustername is the network name of the cluster. For additional information about how to determine the cluster name, click the following article number to view the article in the Microsoft Knowledge Base:

    280770 XADM: The Information Store Does Not Work After You Restore an Offline Backup of an Exchange Server 5.5 and Windows 2000 Cluster

  4. Obtain and run the Profinst.exe utility with no command-line switches. This creates a profile that is named SMTP (Servername {GUID}) where Servername is the name of the Exchange server, and GUID is the globally unique identifier.
  5. Start the Mdbvu32.exe program from the Support\Utils\I386 folder on the Exchange 2000 Server CD-ROM.
  6. In the MAPILogonEx(MAPI_LOGON_UI) dialog box, click to select the MAPI_EXPLICIT_PROFILE check box, and then click OK.
  7. When you are prompted to select a MAPI profile, click PROFINST1 in the Profile Name list, and then click OK.
  8. On the MDB menu, click OpenMessageStore.
  9. Click Private Folders, and then click Open.
  10. On the MDB menu, click Open Root Folder.
  11. Delete the messages in the Temp Tables folders. For example, delete the messages in the TempTable#1 folder. To do so:
    1. Select the message in the folder.
    2. In the Operations available(Select operation, then push Call Function Button) list, click lpFld->DeleteMessages(), and then click Call Function.
    3. When you are finished deleting messages, click Close.
  12. On the MDB menu, click Store Logoff.
  13. Click to select the LOGOFF_ORDERLY check box, and then click OK.
  14. On the message that states the store logoff is complete, click OK.
  15. Quit the MDB Viewer Test Application program.

MORE INFORMATION

The Exchange Temp tables are special-purpose subfolders of the SMTP service's logon to the Message Database. They are used for the creation of the bifurcated messages in the message categorizer, and as temporary storage for SendQ-submitted mail messages if SMTP cannot keep up with the processing of SendQ mail. When the SMTP service logs in to the Message Database, it forces an enumeration and submission of mail in the temp tables. Old messages may be found in the temp tables for one of the following reasons:
  • An error occurs each time the particular message is processed. For example, the Information Store may return a retry-able error when an attempt is made to relay the message, or the connector to the message destination is unavailable.
  • The message was categorized to go to a specific Message Database for local delivery, but the Message Database is no longer available.
  • An unknown or unexpected behavior caused by message damage.
For additional information about a related topic, click the following article number to view the article in the Microsoft Knowledge Base:

253784 XADM: How to Log On to the System Mailbox on Exchange 2000 Server


Modification Type:MajorLast Reviewed:5/19/2003
Keywords:kbClustering kbprb KB812275