Host Name Resolution Does Not Work After One Year When You Use a Hosts File (812175)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP3
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional SP3
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional

SYMPTOMS

When you use a Hosts file for host name resolution on a Windows 2000-based computer, you may find that after a period of approximately one year, host names are no longer resolved to Internet Protocol (IP) addresses.

CAUSE

This problem may occur if you do not restart the computer during a one-year time period. The Time-to-Live (TTL) values for entries in the Hosts file are cached for one year. If you do not restart the computer at any time in a one-year time interval, the TTL values expire, and the entries in the Hosts file must be refreshed before you can use them for name resolution.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The global version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date        Time   Version        Size    File name
------------------------------------------------------
17-Jan-03   14:36  5.0.2195.6656  96,016  Dnsrslvr.dll

WORKAROUND

To work around this problem, restart the computer so that the TTL values for the entries in the Hosts file do not expire.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

MORE INFORMATION

For more information about the Hosts file, see the sample Hosts file in the SystemRoot\System32\Drivers\Etc folder.

Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbDirServices kbWin2kSP4fix kbWin2000preSP4Fix kbfix kbbug KB812175