A Firmware Upgrade Causes the SCSI Device to Be Removed and Redetected (812024)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server SP4
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Server SP4
  • Microsoft Windows 2000 Server SP3
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Professional SP4
  • Microsoft Windows 2000 Professional SP3
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows 2000 Professional SP1

SYMPTOMS

If you upgrade the firmware on a SCSI device (such as a hard disk, a RAID array controller, or a tape drive) and then restart Windows, the Add New Hardware Wizard may run. The wizard prompts you for the location of drivers to install for the upgraded device.

CAUSE

The Windows Plug and Play manager obtains the firmware revision number from SCSI devices. This revision number then becomes part of the device's Plug and Play ID string. When the upgraded device is enumerated, the new firmware revision number causes a new, unique Plug and Play ID for the device to be generated. Therefore, the device is seen as a new device instead of as the same device that had been enumerated previously.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size    File name
   --------------------------------------------------------
   16-Jun-2003  14:18  5.00.2195.6756  74,192  Scsiport.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:

265173 The Datacenter Program and Windows 2000 Datacenter Server Product

For additional information about how to install multiple hotfixes with only one restart, click the following article number to view the article in the Microsoft Knowledge Base:

296861 How to Install Multiple Windows Updates or Hotfixes with Only One Reboot


Modification Type:MinorLast Reviewed:10/18/2005
Keywords:kbHotfixServer kbQFE kbWin2000preSP5Fix kbfix kbbug KB812024 kbAudITPRO kbAudOEM