Information store intermittently stops responding (hangs) when OWA users access public folders (811862)



The information in this article applies to:

  • Microsoft Exchange 2000 Server
  • Microsoft Exchange 2000 Enterprise Server

SYMPTOMS

In certain situations, the Microsoft Exchange 2000 Server Information Store may intermittently stop responding, or "hang," when Microsoft Outlook Web Access (OWA) users access public folders on the server. As a result, OWA users may experience delays and slow performance when they work with public folders.

CAUSE

This issue occurs because of sub-optimal performance logic in the mechanism that allocates buffer pages. When this issue occurs, threads that require buffer pages are blocked by another thread that has a pool of buffer pages locked.

RESOLUTION

Cumulative Rollup Information

To resolve this problem, obtain the September 2003 Exchange 2000 Server Post-Service Pack 3 (SP3) Rollup. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824282 September 2003 Exchange 2000 Server post-Service Pack 3 rollup

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange 2000 Server service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Component: Extensible Storage Engine (ESE)

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version         Size    File name
-------------------------------------------------------
14-Jan-2003  19:59  6.0.6400.0   2,183,168  Ese.dll          

Note Because of file dependencies, this update requires Microsoft Exchange 2000 Server Service Pack 3 (SP3). For more information, click the following article number to view the article in the Microsoft Knowledge Base:

301378 How to obtain the latest Exchange 2000 Server service pack

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.

Modification Type:MinorLast Reviewed:1/25/2006
Keywords:kbHotfixServer kbQFE kbfix kbExchange2000preSP4fix kbbug KB811862 kbAudITPRO