MIT Kerberos v5 Authenticated Users Cannot Access Active Directory Resources (811802)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition



For a Microsoft Windows Server 2000 version of this article, click the following link: Users Who Are Authenticated by MIT Kerberos v5 Cannot Access Active Directory Resources

SYMPTOMS

If you are a Microsoft Windows XP user who is authenticated by an MIT Kerberos v5 realm, you may receive an "Access Denied" error message when you try to access a resource or share in an Active Directory directory service domain.

CAUSE

This problem occurs because multiple Kerberos Ticket-Granting Service Requests (KRB_TGS_REQ) can be sent to a Massachusetts Institute of Technology (MIT) Kerberos v5 Key Distribution Center (KDC) at the same time. If information in any of the most recent requests matches the server name, client name, current time, and microsecond fields of the KRB_TGS_REQ authenticator, the MIT Kerberos v5 KDC will return the "Access Denied" error message.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The global version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   --------------------------------------------------------
   20-Mar-2003  08:40  5.1.2600.1188  272,384  Kerberos.dll 

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

Each authenticator (KRB_AP_REQ), including the ones that are contained in a KRB_TGS_REQ message, must have a different set of these values to avoid being detected as a replay. The other content of the KRB_TGS_REQ message, including the specification where service principal is requested, is not cached. If two KRB_TGS_REQs contain authenticators with the same timestamps, they are seen as a replay attack even if the rest of the authenticator is different (for example, the KRB_TGS_REQs for different principals).

Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbQFE kbWinXPpreSP2fix kbfix kbbug KB811802