Installing Internet Information Services Can Cause Problems in Windows XP (811412)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional SP1

SYMPTOMS

After you install the FTP service or you add the Microsoft Internet Information Services (IIS) component in Windows XP, you may receive a "C000021A" error message on a blue screen before you log on.

CAUSE

This problem may occur if your computer name contains the word "system", for example, "Mysystem" or "System 32". In the setup process or IIS component, IIS Setup removes the IUSER account's permission on critical system files. Because of a string compare problem, it wrongly removes the system account's ACL on system files so you cannot start the computer.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack 2 that contains this fix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   File name
   ---------
   Iis.dll

The Iis.dll file fixes the problem proactively. However, if you receive a "C000021A" error message, and you cannot restart your computer, move the drive to another NTFS operating system, reassign the system - full control permission for files that are in the system32 folder, and then restart the original Windows XP operating system.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

WORKAROUND

To work around this problem, change the computer name.

Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbQFE kbWinXPpreSP2fix kbfix kbbug KB811412