Client issues if hotfix is not installed on all sites that share logon points (811378)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0 SP4

SYMPTOMS

If multiple Systems Management Server (SMS) sites are using Windows Networking Logon Client Installation for the same domain, but do not all have the same hotfixes installed, the SMS clients may experience various problems. All or some of the following symptoms may occur:
  • Smsapm32.exe is not running. The SMS Client Service service periodically starts the program, but it stops immediately again. Because of this behavior, SMS clients do not run any advertisements. Additionally, components that try to communicate with Smsapm32.exe may log an error that is similar to the following:
    Trying to open IPC connection with APM... IPC PIPE : Return code = 0x2; The system cannot find the file specified.~~; Could not open server mail event.
  • Smsmon32.exe may not be able to stop when the computer is shut down because Smsapm32.exe is not running.
  • On a newly installed SMS client, the Systems Management tool in Control Panel shows that only the "Available Programs Manager Win32," "SMS Client Base Components," and "Windows Management" components are installed although other SMS client components have been configured for installation in the SMS Administrator console.
  • The System Offer Data Provider (ODP) or other SMS client components may cause an exception (access violation) and stop unexpectedly. Because of this, SMS clients do not receive any advertisements.
  • Some programs may not start or may seem to stop responding ( hang). For example, this may occur with Rumba 2000.

CAUSE

This problem first occurred with the SMS Service Pack 3 (SP3) fix that is described in Microsoft Knowledge Base article 293187. This hotfix added dependencies between various components in Clicore.exe and most of the client components that are located on Client Access Points (for example, Apasetup.exe and Swdist32.exe).

If an SMS hotfix that contains the Clicore.exe file is installed on an SMS site server that has Windows Networking Logon Client Installation in use, Clicore.exe is automatically copied to all domain controllers. SMS clients that are assigned to an SMS site where the hotfix has not yet been installed still install the files that are contained in Clicore.exe from a domain controller (an SMS logon point) the next time the Smsls.bat or Smsman.exe runs. This occurs with new client installations and with upgrades. This can cause the SMS client issues that are described in this article to occur because some of the files in Clicore.exe may not be compatible with the files that are currently installed from the Client Access Point (CAP). For example, Clibase.dll in Clicore.exe on an SMS logon point may not be compatible with the version of Smsapm32.exe in Apasetup.exe on a CAP.

This problem may also occur even if all the SMS sites are using the same hotfix if you have used the Cliupgrade.exe utility from the SMS Support Tools with the /DISABLE switch. Using this command instructs Client Configuration Installation Manager (CCIM) on an SMS client not to download and upgrade any of its components from a CAP. This can leave the client in a state where it is partially upgraded; a key component such as Smsapm32.exe may not function. Be careful when you use this utility after installing a new version of Clicore.exe on the SMS logon points. SMS software distribution to clients may not be available to easily permit client upgrades from CAPs again by using the cliupgrade /ENABLE command.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Systems Management Server 2.0. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

288239 How to obtain the latest Systems Management Server 2.0 service pack

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Systems Management Server service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.The English version of this fix for SMS 2.0 Service Pack 4 (SP4) sites has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name     Platform
   ------------------------------------------------------------------
   01-May-2002  18:20  2.0.1493.4168  188,784  Nt_logon.dll  x86
   01-May-2002  18:20  2.0.1493.4168  336,144  Nt_logon.dll  Alpha
Note Because of file dependencies, the most recent hotfix or feature that contains these files may also contain additional files.

How to Install the Hotfix

Using the Hotfix Installer

Note This method is only for Intel-based computers.
  1. Create a folder in a location that is accessible to your SMS site servers.
  2. Copy the update file (Q811378.exe) and platform folders to the new folder. The folder structure must be such that the update file is located one folder above the platform folders.
  3. From each of the primary and secondary SMS site servers in your environment, log on to your site server by using an account with administrator credentials.
  4. Quit the SMS Administrator console if it is running.
  5. Run Q811378.exe, and then follow the instructions in the wizard.

Performing a Manual Installation

  1. Create a folder in a location that is accessible to your SMS site servers.
  2. Copy the platform folders that contain the hotfix files to the folder that you created.
  3. From each of the primary and secondary SMS site servers in your environment, log on to your site server by using an account with administrator credentials.
  4. Quit the SMS Administrator console if it is running.
  5. Stop all SMS services.
  6. Replace the Nt_logon.dll file in the SmsRootFolder\Bin\Platform folder with the version from the hotfix.
  7. Perform a site reset. To do this, click Start, point to Programs, point to Systems Management Server, and then click SMS Setup. Click Next, click Next, and then click Modify or reset the current installation.

WORKAROUND

If you must install an SMS hotfix that contains an updated Clicore.exe file, install the fix as soon as possible on all SMS site servers that are using the same domain for SMS logon points (using Windows Networking Logon Client Installation). This issue does not occur if all the SMS sites have the same hotfixes installed (unless you have used Cliupgrade.exe as noted earlier in this article). It is a good idea to keep all SMS site servers that share a domain for SMS logon points using the same service pack and hotfixes.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

Note that an SMS client installs a new Clicore.exe file from an SMS logon point only if the new Clicore.exe file is for the same SMS service pack. If the client finds a Clicore.exe file from a newer SMS service pack than the client is running, the client does not install the new Clicore.exe file. Instead, the client waits for CCIM to upgrade the client components from a CAP.

The updated SMS Logon Server Manager (LSM) that is installed with this hotfix keeps the lowest version of the Clicore.exe and Clicor16.exe files among all the sites on the SMS logon points. Previously, the site that had the highest versions of these files uploaded them to the primary domain controller (PDC) or the PDC Emulator. With this hotfix, LSM keeps track of the site with the lowest version of these files in the new SITE CODE value under the VERSION ENFORCING SITE section in Copylog.tcf file on the PDC.

Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbMiscTools kbfix kbBug kbSMS200preSP5fix KB811378