Error message when you try to add a new printer in Windows 2000 Professional (811348)



The information in this article applies to:

  • Microsoft Windows 2000 Professional

SYMPTOMS

When you click Start, click Printers and Faxes, and then click Add Printer, you may receive the following error messages:
Printer operation cannot continue due to lack of resources. Access is denied.
Out of resources: Printer operation cannot continue due to lack of resources. The print subsystem is unavailable.
The Print Spooler service may be stopped. When you try to restart this service, you may receive the following error message:
Error 1069: The service did not start due to a logon failure.

CAUSE

This problem may occur if the Print Spooler service is configured with a user account or a password that is not valid.

RESOLUTION

To resolve this problem, configure the Print Spooler service to use the Local System account. To do so:
  1. Click Start, click Control Panel, and then double-click Administrative Tools.
  2. Double-click Services.
  3. Double-click Print Spooler in the list to open the property pages for the service.
  4. Click the Log On tab.
  5. Under Log on as:, make sure that the Local System Account option is selected.
  6. Make sure that the Allow service to interact with desktop check box is selected.
  7. On the General tab, click Stop to stop the service, and then click Start to restart the service.
  8. Click OK, and then close all the dialog boxes.
You should now be able to add a new printer. For more information about how to troubleshoot printer problems in Windows 2000, click the following article number to view the article in the Microsoft Knowledge Base:

260142 How to troubleshoot Windows 2000 printing problems

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:1/3/2006
Keywords:KB811348