Error Message: The Event Log File Is Corrupt (811145)



The information in this article applies to:

  • Microsoft Windows NT Advanced Server
  • Microsoft Windows NT Server
  • Microsoft Windows NT 4.0

SYMPTOMS

When you try to open any event in the Event Viewer Application Log, you receive the following error message:
The event log file is corrupt.

CAUSE

This error message occurs because of a problem with the Dr. Watson Error Debugging program.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.


The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
 
      Date      Time    Version            Size    File name     Platform
 ----------------------------------------------------------------------------
   03-Feb-2003  12:29  4.0.1381.7208      46,864  Eventlog.dll     x86
Note Because of file dependencies, this hotfix requires Microsoft Windows NT 4.0 Service Pack 6a.


STATUS

Microsoft has confirmed that this is a problem in Windows NT 4.0.

Modification Type:MinorLast Reviewed:9/27/2005
Keywords:kbHotfixServer kbQFE kberrmsg kbfix kbbug KB811145